summaryrefslogtreecommitdiff
path: root/recipes-bsp/multitech/mtac-mfser_1.0.0.bb
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2018-10-25 18:15:07 -0500
committerJohn Klug <john.klug@multitech.com>2018-10-25 18:15:07 -0500
commite81526169d59e57fa0490e0433d693595308f81a (patch)
tree9c7ff4763979bda2868e4ba0d5116472b0740b9b /recipes-bsp/multitech/mtac-mfser_1.0.0.bb
parentf5e8bc4c61fde5701f162cf62b2bd676b0377802 (diff)
downloadmeta-multitech-e81526169d59e57fa0490e0433d693595308f81a.tar.gz
meta-multitech-e81526169d59e57fa0490e0433d693595308f81a.tar.bz2
meta-multitech-e81526169d59e57fa0490e0433d693595308f81a.zip
Fix up module unload with new mtac_free function in the mtac module4.0.4
Diffstat (limited to 'recipes-bsp/multitech/mtac-mfser_1.0.0.bb')
-rw-r--r--recipes-bsp/multitech/mtac-mfser_1.0.0.bb45
1 files changed, 0 insertions, 45 deletions
diff --git a/recipes-bsp/multitech/mtac-mfser_1.0.0.bb b/recipes-bsp/multitech/mtac-mfser_1.0.0.bb
deleted file mode 100644
index fe09af2..0000000
--- a/recipes-bsp/multitech/mtac-mfser_1.0.0.bb
+++ /dev/null
@@ -1,45 +0,0 @@
-DESCRIPTION = "MTAC Multi-Function Serial Card"
-HOMEPAGE = "http://www.multitech.net/developer/products/multiconnect-conduit-platform/accessory-cards/mtac-mfser/"
-SECTION = "base"
-PRIORITY = "optional"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
-DEPENDS = "virtual/kernel mtac mts-io"
-RDEPENDS_${PN} = "kernel-module-mtac"
-INC_PR = "r0"
-
-SRCREV = "${PV}"
-
-PR = "${INC_PR}.0-${MLINUX_KERNEL_VERSION}${MLINUX_KERNEL_EXTRA_VERSION}"
-
-SRC_URI = " \
- git://git.multitech.net/mtac-mfser.git;protocol=git \
-"
-S = "${WORKDIR}/git"
-
-inherit module
-
-EXTRA_OEMAKE = " -C ${STAGING_KERNEL_DIR} \
- KBUILD_VERBOSE=1 \
- M=${S} \
- modules \
- "
-
-do_compile () {
- bbnote make "$@"
- make "$@"
- unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
- oe_runmake
-}
-
-PACKAGES = "kernel-module-${PN}"
-
-FILES_kernel-module-${PN} = "${base_libdir}/modules/${KERNEL_VERSION}/extra/mtac_mfser.ko"
-
-PARALLEL_MAKE = ""
-
-fakeroot do_install () {
- install -m 0755 -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra
- # use cp instead of install so the driver doesn't get stripped
- cp ${S}/mtac_mfser.ko ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra
-}