summaryrefslogtreecommitdiff
path: root/recipes-bsp/multitech/get-eeprom-device-info_1.0.0.bb
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2017-12-07 11:56:03 -0600
committerJohn Klug <john.klug@multitech.com>2018-03-01 12:21:33 -0600
commit718ec50ea66d0720e3e3b2ade5632f04c0f84122 (patch)
treec90d05d8c516d696ec4a5150e5209c9479dbee76 /recipes-bsp/multitech/get-eeprom-device-info_1.0.0.bb
parent21ad0c79ceadedec4c7c2f702c5cea8cb2a96693 (diff)
downloadmeta-multitech-718ec50ea66d0720e3e3b2ade5632f04c0f84122.tar.gz
meta-multitech-718ec50ea66d0720e3e3b2ade5632f04c0f84122.tar.bz2
meta-multitech-718ec50ea66d0720e3e3b2ade5632f04c0f84122.zip
Add /run/config populating script, get-eeprom-device-info
Diffstat (limited to 'recipes-bsp/multitech/get-eeprom-device-info_1.0.0.bb')
-rw-r--r--recipes-bsp/multitech/get-eeprom-device-info_1.0.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-bsp/multitech/get-eeprom-device-info_1.0.0.bb b/recipes-bsp/multitech/get-eeprom-device-info_1.0.0.bb
new file mode 100644
index 0000000..90e8b60
--- /dev/null
+++ b/recipes-bsp/multitech/get-eeprom-device-info_1.0.0.bb
@@ -0,0 +1,23 @@
+# Script to copy the EEPROM to /run/config
+PR = "r0"
+DESCRIPTION = "EEPROM copyting tool"
+HOMEPAGE = "http://www.multitech.net/"
+SECTION = "console/utils"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.GPLv2;md5=751419260aa954499f7abaabaa882bbe"
+RDEPENDS_${PN} =+ "bash"
+
+SRCREV = "${PV}"
+
+SRC_URI = "file://${PN}.sh"
+
+PARALLEL_MAKE = ""
+
+
+fakeroot do_install_append() {
+ # install MTCAP mts-io init script
+ install -d 0755 ${D}${base_sbindir}
+ install -m 0755 ${WORKDIR}/${PN}.sh ${D}${base_sbindir}/${PN}
+}
+