summaryrefslogtreecommitdiff
path: root/recipes-bsp/at91bootstrap/at91bootstrap_3.5.3.bb.orig
diff options
context:
space:
mode:
authorJeff Hatch <jhatch@multitech.com>2017-02-13 14:34:15 -0600
committerJohn Klug <john.klug@multitech.com>2017-06-09 09:09:19 -0500
commitcc54a92a36f5fcd65e69f51060c4147286d22b62 (patch)
tree528e8c203b35f37d71fefb49b396b2a721980daa /recipes-bsp/at91bootstrap/at91bootstrap_3.5.3.bb.orig
parent8ed17578476277bad96ae473bb7d533a97cc9d46 (diff)
downloadmeta-multitech-cc54a92a36f5fcd65e69f51060c4147286d22b62.tar.gz
meta-multitech-cc54a92a36f5fcd65e69f51060c4147286d22b62.tar.bz2
meta-multitech-cc54a92a36f5fcd65e69f51060c4147286d22b62.zip
Initial commit of Yocto 2.1 changes
Diffstat (limited to 'recipes-bsp/at91bootstrap/at91bootstrap_3.5.3.bb.orig')
-rw-r--r--recipes-bsp/at91bootstrap/at91bootstrap_3.5.3.bb.orig30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-bsp/at91bootstrap/at91bootstrap_3.5.3.bb.orig b/recipes-bsp/at91bootstrap/at91bootstrap_3.5.3.bb.orig
new file mode 100644
index 0000000..2e5f086
--- /dev/null
+++ b/recipes-bsp/at91bootstrap/at91bootstrap_3.5.3.bb.orig
@@ -0,0 +1,30 @@
+require at91bootstrap_3.5.inc
+
+PR = "r3"
+
+LICENSE = "custom-freely-distributable"
+LIC_FILES_CHKSUM = "file://main.c;beginline=6;endline=26;md5=6fca71334c9e8b7d033296123c91437f"
+
+SRCREV = "v${PV}"
+SRC_URI = "git://github.com/linux4sam/at91bootstrap \
+ file://at91bootstrap-3.5.2-add-install.patch \
+ file://at91bootstrap-3.5.2-onetime-slow-clock-switch.patch \
+ file://at91sam9x5_4bit_pmecc_header.bin \
+ file://at91bootstrap-3.5.3-disable-rtc-interrupts.patch"
+
+S = "${WORKDIR}/git"
+
+SRC_URI_append_mtcdt = " file://at91bootstrap-3.5.3-mtcdt.patch "
+SRC_URI_append_mtcap = " file://at91bootstrap-3.5.3-mtcdt.patch "
+
+# generate a bootstrap file padded with the header needed for 4-bit PMECC
+# The padded file can be flashed via u-boot without any need to set the PMECC header using SAM-BA
+do_pad_4bit_pmecc() {
+ cp -f ${WORKDIR}/at91sam9x5_4bit_pmecc_header.bin ${DEPLOY_DIR_IMAGE}/at91bootstrap_pmecc_padded.bin
+ cat ${DEPLOY_DIR_IMAGE}/at91bootstrap.bin >> ${DEPLOY_DIR_IMAGE}/at91bootstrap_pmecc_padded.bin
+}
+
+do_install_append() {
+ do_pad_4bit_pmecc
+}
+