summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesse Gilles <jgilles@multitech.com>2015-01-13 13:56:35 -0600
committerJesse Gilles <jgilles@multitech.com>2015-01-13 13:56:35 -0600
commit5d10cdb5b84871bba20f0f47ae77565ede84ee7f (patch)
tree7c94bfe9400977b6c58d0810b114077216bc5cef
parent709b09dfbf0c69f4cbc0ab006ca573f3e670667c (diff)
downloadmeta-multitech-5d10cdb5b84871bba20f0f47ae77565ede84ee7f.tar.gz
meta-multitech-5d10cdb5b84871bba20f0f47ae77565ede84ee7f.tar.bz2
meta-multitech-5d10cdb5b84871bba20f0f47ae77565ede84ee7f.zip
u-boot-2012.10: mtcdt: update to 256MB RAM
-rw-r--r--recipes-bsp/u-boot/u-boot-2012.10/u-boot-2012.10-mtcdt.patch34
-rw-r--r--recipes-bsp/u-boot/u-boot_2012.10.bb2
2 files changed, 28 insertions, 8 deletions
diff --git a/recipes-bsp/u-boot/u-boot-2012.10/u-boot-2012.10-mtcdt.patch b/recipes-bsp/u-boot/u-boot-2012.10/u-boot-2012.10-mtcdt.patch
index fbc9c0f..dc27dbb 100644
--- a/recipes-bsp/u-boot/u-boot-2012.10/u-boot-2012.10-mtcdt.patch
+++ b/recipes-bsp/u-boot/u-boot-2012.10/u-boot-2012.10-mtcdt.patch
@@ -1,7 +1,7 @@
Index: git/include/configs/at91sam9x5ek.h
===================================================================
---- git.orig/include/configs/at91sam9x5ek.h 2014-10-14 16:14:47.208402129 -0500
-+++ git/include/configs/at91sam9x5ek.h 2014-10-21 11:20:03.467770688 -0500
+--- git.orig/include/configs/at91sam9x5ek.h 2015-01-13 13:31:45.378882027 -0600
++++ git/include/configs/at91sam9x5ek.h 2015-01-13 13:31:45.762877122 -0600
@@ -54,6 +54,7 @@
#define CONFIG_USART_ID ATMEL_ID_SYS
@@ -26,6 +26,15 @@ Index: git/include/configs/at91sam9x5ek.h
/*
* BOOTP options
+@@ -93,7 +100,7 @@
+ /* SDRAM */
+ #define CONFIG_NR_DRAM_BANKS 1
+ #define CONFIG_SYS_SDRAM_BASE 0x20000000
+-#define CONFIG_SYS_SDRAM_SIZE 0x08000000 /* 128 megs */
++#define CONFIG_SYS_SDRAM_SIZE 0x10000000 /* 256 megs */
+
+ #define CONFIG_SYS_INIT_SP_ADDR \
+ (CONFIG_SYS_SDRAM_BASE + 4 * 1024 - GENERATED_GBL_DATA_SIZE)
@@ -120,12 +127,14 @@
/* our CLE is AD22 */
#define CONFIG_SYS_NAND_MASK_CLE (1 << 22)
@@ -43,7 +52,7 @@ Index: git/include/configs/at91sam9x5ek.h
#define CONFIG_PMECC_SECTOR_SIZE 512
#define CONFIG_PMECC_INDEX_TABLE_OFFSET 0x8000
-@@ -143,6 +152,8 @@
+@@ -143,21 +152,22 @@
#define CONFIG_RMII
#define CONFIG_NET_RETRY_COUNT 20
#define CONFIG_MACB_SEARCH_PHY
@@ -52,7 +61,11 @@ Index: git/include/configs/at91sam9x5ek.h
#define CONFIG_SYS_LOAD_ADDR 0x22000000 /* load address */
-@@ -153,11 +164,10 @@
+ #define CONFIG_SYS_MEMTEST_START CONFIG_SYS_SDRAM_BASE
+-#define CONFIG_SYS_MEMTEST_END 0x26e00000
++#define CONFIG_SYS_MEMTEST_END 0x2ee00000
+
+ #ifdef CONFIG_SYS_USE_NANDFLASH
/* bootstrap + u-boot + env + linux in nandflash */
#define CONFIG_ENV_IS_IN_NAND
#define CONFIG_ENV_OFFSET 0xc0000
@@ -77,7 +90,7 @@ Index: git/include/configs/at91sam9x5ek.h
- "root=/dev/mtdblock1 rw " \
- "rootfstype=ubifs ubi.mtd=1 root=ubi0:rootfs"
+/* MTCDT uses jffs2 */
-+#define CONFIG_BOOTARGS "mem=128M console=ttyS0,115200 root=/dev/mtdblock8 ro rootfstype=jffs2"
++#define CONFIG_BOOTARGS "mem=256M console=ttyS0,115200 root=/dev/mtdblock8 ro rootfstype=jffs2"
#define CONFIG_BAUDRATE 115200
@@ -106,8 +119,8 @@ Index: git/include/configs/at91sam9x5ek.h
#endif
Index: git/board/atmel/at91sam9x5ek/at91sam9x5ek.c
===================================================================
---- git.orig/board/atmel/at91sam9x5ek/at91sam9x5ek.c 2014-10-14 16:14:46.920406821 -0500
-+++ git/board/atmel/at91sam9x5ek/at91sam9x5ek.c 2014-10-14 16:14:47.664394700 -0500
+--- git.orig/board/atmel/at91sam9x5ek/at91sam9x5ek.c 2015-01-13 13:31:44.950887504 -0600
++++ git/board/atmel/at91sam9x5ek/at91sam9x5ek.c 2015-01-13 13:31:45.762877122 -0600
@@ -61,7 +61,8 @@
csa = readl(&matrix->ebicsa);
csa |= AT91_MATRIX_EBI_CS3A_SMC_SMARTMEDIA;
@@ -141,3 +154,10 @@ Index: git/board/atmel/at91sam9x5ek/at91sam9x5ek.c
return 0;
}
+
+Index: git/board/atmel/at91sam9x5ek/config.mk
+===================================================================
+--- git.orig/board/atmel/at91sam9x5ek/config.mk 2015-01-13 13:31:44.950887504 -0600
++++ git/board/atmel/at91sam9x5ek/config.mk 2015-01-13 13:41:46.576072758 -0600
+@@ -1 +1 @@
+-CONFIG_SYS_TEXT_BASE = 0x26f00000
++CONFIG_SYS_TEXT_BASE = 0x2ef00000
diff --git a/recipes-bsp/u-boot/u-boot_2012.10.bb b/recipes-bsp/u-boot/u-boot_2012.10.bb
index 9763e0a..8dfd69d 100644
--- a/recipes-bsp/u-boot/u-boot_2012.10.bb
+++ b/recipes-bsp/u-boot/u-boot_2012.10.bb
@@ -1,4 +1,4 @@
-PR = "r4"
+PR = "r5"
require u-boot.inc
LICENSE = "GPLv2"