summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2017-08-30 09:58:46 -0500
committerJohn Klug <john.klug@multitech.com>2017-08-30 09:58:46 -0500
commita7bebbbcae2bf00408ea598e21e27aa646370240 (patch)
tree3991dae81cd4143cf4e448a0e5b4e726b5015b10
parentf6bcb4f9b822f6b49d7ba28a97d117b620d0a85b (diff)
downloadmeta-multitech-a7bebbbcae2bf00408ea598e21e27aa646370240.tar.gz
meta-multitech-a7bebbbcae2bf00408ea598e21e27aa646370240.tar.bz2
meta-multitech-a7bebbbcae2bf00408ea598e21e27aa646370240.zip
merge error
-rw-r--r--recipes-kernel/linux/linux_3.12.27.bb.old72
-rw-r--r--recipes-kernel/linux/linux_3.12.27.bb.orig59
2 files changed, 0 insertions, 131 deletions
diff --git a/recipes-kernel/linux/linux_3.12.27.bb.old b/recipes-kernel/linux/linux_3.12.27.bb.old
deleted file mode 100644
index 5f1851d..0000000
--- a/recipes-kernel/linux/linux_3.12.27.bb.old
+++ /dev/null
@@ -1,72 +0,0 @@
-inherit kernel
-# mts class to build dtb and append to kernel image
-inherit linux-append-dtb
-
-PR = "r13"
-
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
-
-DEPENDS += "xz-native bc-native"
-
-SRC_URI = "https://www.kernel.org/pub/linux/kernel/v3.x/linux-${PV}.tar.gz \
-"
-
-S = "${WORKDIR}/${PN}-${PV}"
-
-COMMON_PATCHES = " \
- file://linux-3.12-gpio-expose-pullups.patch \
- file://linux-3.12-gpio-expose-deglitch.patch \
- file://linux-3.12-atmel-spi.patch \
- file://linux-3.12-atmel-mci-force-detect.patch \
- file://linux-3.12-atmel-pmecc-debug-bitflips.patch \
- file://linux-3.12-at91sam9_wdt-10second-timeout.patch \
- file://linux-3.12.27-option-telit.patch \
- file://linux-3.12-cdc-acm-ignore-exar-devices.patch \
- file://linux-3.12-release-rfcomm-port-fix.patch \
- file://linux-3.12-spi-atmel-dma-min.patch \
- file://linux-3.12.27-USB-option-reduce-interrupt-urb-logging-verbosity.patch \
- file://linux-3.12-pps-gpio.patch \
- file://linux-3.12-cadence-macb.patch \
- file://linux-3.12-time-leap-second-v3.patch \
- "
-
-SRC_URI_append_mtcdt = "\
- ${COMMON_PATCHES} \
- file://defconfig \
- file://linux-3.12-eeprom-setup-mtcdt.patch \
- file://linux-3.12-mtcdt-device-tree.patch \
- file://linux-3.12-add-num_accessory_ports-config-option.patch \
- file://linux-3.12-usb-serial-simple-telit.patch \
- "
-
-SRC_URI_append_mtcap = "\
- ${COMMON_PATCHES} \
- file://defconfig \
- file://linux-3.12-eeprom-setup-mtcdt.patch \
- file://linux-3.12-mtcap-device-tree.patch \
- file://linux-3.12-add-num_accessory_ports-config-option.patch \
- "
-
-SRC_URI[md5sum] = "2f05332bfca89ae1348ae454af2f5ffb"
-SRC_URI[sha256sum] = "2014c55257dda311779359d6b42931079a687c154777cc528c44e25f262194cd"
-
-COMPATIBLE_MACHINE = "(mtcdt|mtcap)"
-DTB_APPEND_mtcdt = "mtcdt"
-DTB_APPEND_mtcap = "mtcap"
-do_patch_append() {
- # Makefile location
- makefl="${S}" + "/Makefile"
- # String to find: EXTRAVERSION =
- original="'^(.*EXTRAVERSION[[:space:]]*=)[[:space:]]*'"
- # Update for string Copy variable = and set to PR version
- upd="'\\1 " + "${PR}" + "'"
- # Use sed to write the data to the file.
- print "Setting EXTRAVERSION to ${PR}\n"
- os.system("sed -ri -e s/" + original + "/" + upd + "/ " + makefl)
-}
-
-# disable this on purpose for dev purposes
-do_rm_work() {
- echo "skipping"
-}
diff --git a/recipes-kernel/linux/linux_3.12.27.bb.orig b/recipes-kernel/linux/linux_3.12.27.bb.orig
deleted file mode 100644
index 1d82e66..0000000
--- a/recipes-kernel/linux/linux_3.12.27.bb.orig
+++ /dev/null
@@ -1,59 +0,0 @@
-inherit kernel
-# mts class to build dtb and append to kernel image
-inherit linux-append-dtb
-
-PR = "r12"
-
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
-
-DEPENDS += "xz-native bc-native"
-
-SRC_URI = "https://www.kernel.org/pub/linux/kernel/v3.x/linux-${PV}.tar.gz \
-"
-
-S = "${WORKDIR}/${PN}-${PV}"
-
-COMMON_PATCHES = " \
- file://linux-3.12-gpio-expose-pullups.patch \
- file://linux-3.12-gpio-expose-deglitch.patch \
- file://linux-3.12-atmel-spi.patch \
- file://linux-3.12-atmel-mci-force-detect.patch \
- file://linux-3.12-atmel-pmecc-debug-bitflips.patch \
- file://linux-3.12-at91sam9_wdt-10second-timeout.patch \
- file://linux-3.12.27-option-telit.patch \
- file://linux-3.12-cdc-acm-ignore-exar-devices.patch \
- file://linux-3.12-release-rfcomm-port-fix.patch \
- file://linux-3.12-spi-atmel-dma-min.patch \
- file://linux-3.12.27-USB-option-reduce-interrupt-urb-logging-verbosity.patch \
- file://linux-3.12-pps-gpio.patch \
- file://linux-3.12-cadence-macb.patch \
- "
-
-SRC_URI_append_mtcdt = "\
- ${COMMON_PATCHES} \
- file://defconfig \
- file://linux-3.12-eeprom-setup-mtcdt.patch \
- file://linux-3.12-mtcdt-device-tree.patch \
- file://linux-3.12-add-num_accessory_ports-config-option.patch \
- "
-
-SRC_URI_append_mtcap = "\
- ${COMMON_PATCHES} \
- file://defconfig \
- file://linux-3.12-eeprom-setup-mtcdt.patch \
- file://linux-3.12-mtcap-device-tree.patch \
- file://linux-3.12-add-num_accessory_ports-config-option.patch \
- "
-
-SRC_URI[md5sum] = "2f05332bfca89ae1348ae454af2f5ffb"
-SRC_URI[sha256sum] = "2014c55257dda311779359d6b42931079a687c154777cc528c44e25f262194cd"
-
-COMPATIBLE_MACHINE = "(mtcdt|mtcap)"
-DTB_APPEND_mtcdt = "mtcdt"
-DTB_APPEND_mtcap = "mtcap"
-
-# disable this on purpose for dev purposes
-do_rm_work() {
- echo "skipping"
-}