summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrii Pientsov <andrii.pientsov@globallogic.com>2021-04-22 22:58:22 +0300
committerAndrii Pientsov <andrii.pientsov@globallogic.com>2021-04-22 22:58:22 +0300
commit9fa3081c921e5352c9bf5229ac826f443b575e79 (patch)
treed6c07782f6e5d4e02f1b1ef4cdcb9516fc890318
parentdfc9a0c9ec8d19c2b0eee9c8ccaff5cc75bbc4c3 (diff)
downloadmeta-multitech-9fa3081c921e5352c9bf5229ac826f443b575e79.tar.gz
meta-multitech-9fa3081c921e5352c9bf5229ac826f443b575e79.tar.bz2
meta-multitech-9fa3081c921e5352c9bf5229ac826f443b575e79.zip
MTX-4009 SEL-2021: The device stops booting when performing reboot via Pinhole button - GP-1191
-rw-r--r--recipes-bsp/multitech/radio-reset_0.1.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/recipes-bsp/multitech/radio-reset_0.1.bb b/recipes-bsp/multitech/radio-reset_0.1.bb
index 65c6e09..53060a5 100644
--- a/recipes-bsp/multitech/radio-reset_0.1.bb
+++ b/recipes-bsp/multitech/radio-reset_0.1.bb
@@ -42,6 +42,14 @@ fakeroot do_install_append_mtrv1() {
sed -i 's/ONSTOP="yes"/ONSTOP="no"/g' ${D}${sysconfdir}/default/radio-reset
}
+fakeroot do_install_append_mtre() {
+ # enable radio-reset on start for the mtre hardware
+ sed -i 's/ONSTART="no"/ONSTART="yes"/g' ${D}${sysconfdir}/default/radio-reset
+
+ # disable radio-reset on shutdown for the mtre hardware
+ sed -i 's/ONSTOP="yes"/ONSTOP="no"/g' ${D}${sysconfdir}/default/radio-reset
+}
+
fakeroot do_install_append_mtcap() {
# disable radio-reset both on start and on shutdown for the mtcap hardware
# mtcap issues the radio reset in /etc/init.d/mts-io init script