summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2021-10-07 10:09:12 -0500
committerJohn Klug <john.klug@multitech.com>2021-12-29 08:05:37 -0600
commit355a5e985b885530c3c33163aa01fb42f5baa7eb (patch)
tree6da317e0b9f28d2191a1b5177aa668b03a5618ef
parent472923f82503b6a1b6919c2fd91eebab3a307b36 (diff)
downloadmeta-multitech-355a5e985b885530c3c33163aa01fb42f5baa7eb.tar.gz
meta-multitech-355a5e985b885530c3c33163aa01fb42f5baa7eb.tar.bz2
meta-multitech-355a5e985b885530c3c33163aa01fb42f5baa7eb.zip
Development patch for MTCDT-0.2 mts-io
-rw-r--r--recipes-bsp/multitech/mts-io.inc3
-rw-r--r--recipes-bsp/multitech/mts-io/MTCDT-0.2.patch71
2 files changed, 73 insertions, 1 deletions
diff --git a/recipes-bsp/multitech/mts-io.inc b/recipes-bsp/multitech/mts-io.inc
index 90cd095..65e7c2c 100644
--- a/recipes-bsp/multitech/mts-io.inc
+++ b/recipes-bsp/multitech/mts-io.inc
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://io-module/COPYING;md5=94d55d512a9ba36caa9b7df079bae19
file://io-tool/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
"
do_fetch[depends] += "virtual/kernel:do_shared_workdir"
-INC_PR = "r3"
+INC_PR = "r4"
SRCREV = "${PV}"
PR = "${INC_PR}.0-${KERNEL_MODULE_PACKAGE_SUFFIX}"
@@ -26,6 +26,7 @@ SRC_URI = " \
file://mts-io.blacklist \
file://mts-io.mtcap.init \
file://mts-io.conf \
+ file://MTCDT-0.2.patch \
"
S = "${WORKDIR}/git"
diff --git a/recipes-bsp/multitech/mts-io/MTCDT-0.2.patch b/recipes-bsp/multitech/mts-io/MTCDT-0.2.patch
new file mode 100644
index 0000000..77c7457
--- /dev/null
+++ b/recipes-bsp/multitech/mts-io/MTCDT-0.2.patch
@@ -0,0 +1,71 @@
+diff --git a/configure.ac b/configure.ac
+index 7c25e08..27696b9 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1,4 +1,4 @@
+-AC_INIT([mts-io], [4.7.2])
++AC_INIT([mts-io], [4.7.3])
+ AC_CONFIG_SRCDIR([util/mts_util_lora2_reset.c])
+ AM_INIT_AUTOMAKE
+ AM_CONFIG_HEADER([config.h])
+diff --git a/io-module/mts-io.c b/io-module/mts-io.c
+index ed0cb49..6fad83f 100644
+--- a/io-module/mts-io.c
++++ b/io-module/mts-io.c
+@@ -80,6 +80,13 @@ MODULE_DEVICE_TABLE(of, mts_io_dt_ids);
+ /* on-board EEPROM */
+ static struct mts_id_eeprom_layout id_eeprom;
+
++// Allow other modules to query the hardware version
++const char *mts_get_hw_version(void)
++{
++ return id_eeprom.hw_version;
++}
++EXPORT_SYMBOL(mts_get_hw_version);
++
+ #include "adc.c"
+
+ static int mts_io_probe(struct platform_device *pdev)
+@@ -544,6 +551,9 @@ static DEVICE_ATTR_MTS(dev_attr_led_d_gpio, "led-d",
+ static DEVICE_ATTR_MTS(dev_attr_led_e_gpio, "led-e",
+ mts_attr_show_gpio_pin, mts_attr_store_gpio_pin);
+
++
++
++
+ /* eeprom info */
+ static ssize_t mts_attr_show_product_info(struct device *dev,
+ struct device_attribute *attr,
+diff --git a/io-module/mts_io.h b/io-module/mts_io.h
+index 2c4b7b6..4f46804 100644
+--- a/io-module/mts_io.h
++++ b/io-module/mts_io.h
+@@ -50,6 +50,7 @@ struct gpio_pin {
+ };
+
+ extern int mts_has_radio(const char *product_id, size_t len);
++extern const char *mts_get_hw_version(void);
+
+ #endif /* __MTS_IO_H */
+
+diff --git a/io-module/mts_io_module.h b/io-module/mts_io_module.h
+index eca15a3..83a2994 100644
+--- a/io-module/mts_io_module.h
++++ b/io-module/mts_io_module.h
+@@ -5,7 +5,7 @@
+ * MTAC cards.
+ */
+
+-#define DRIVER_VERSION "v4.7.2"
++#define DRIVER_VERSION "v4.7.3"
+ #define DRIVER_AUTHOR "Multitech Systems"
+ #define DRIVER_DESC "MTS-IO Controller"
+ #define DRIVER_NAME "mts-io"
+@@ -36,6 +36,7 @@
+ #define HW_VERSION_MTRE "MTRE-0.0"
+ #define HW_VERSION_MTCDT_0_0 "MTCDT-0.0" // No GPS or WiFi Capability
+ #define HW_VERSION_MTCDT_0_1 "MTCDT-0.1" // Conduit refresh with GPS and WiFi possible
++#define HW_VERSION_MTCDT_0_2 "MTCDT-0.2" // FTDI with no multi-drop serial support
+ #define HW_VERSION_MTCDTIP_0_0 "MTCDTIP-0.0"
+ #define HW_VERSION_MTCDTIPHP_0_0 "MTCDTIPHP-0.0" // Also known as LoRa 2.1
+ #define HW_VERSION_MTCAP_0_0 "MTCAP-0.0"