summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2021-09-24 04:25:12 -0500
committerJohn Klug <john.klug@multitech.com>2021-12-29 08:05:37 -0600
commit32e3a75c42a18e5196f15125f3844499faee5d71 (patch)
treed4f0bbf5f47688f35cbb21a609c792c062875c37
parent2e57f0fcfd0d693aa8d5e6f1c8c380ab0271608b (diff)
downloadmeta-multitech-32e3a75c42a18e5196f15125f3844499faee5d71.tar.gz
meta-multitech-32e3a75c42a18e5196f15125f3844499faee5d71.tar.bz2
meta-multitech-32e3a75c42a18e5196f15125f3844499faee5d71.zip
Use dtc-native, rather than /usr/bin/dtc to compile overlays
-rw-r--r--recipes-bsp/multitech/mt-dt-overlay_1.0.4.bb9
1 files changed, 6 insertions, 3 deletions
diff --git a/recipes-bsp/multitech/mt-dt-overlay_1.0.4.bb b/recipes-bsp/multitech/mt-dt-overlay_1.0.4.bb
index 8aa62b4..93272fb 100644
--- a/recipes-bsp/multitech/mt-dt-overlay_1.0.4.bb
+++ b/recipes-bsp/multitech/mt-dt-overlay_1.0.4.bb
@@ -6,7 +6,7 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
inherit update-rc.d
INITSCRIPT_NAME = "${PN}"
INITSCRIPT_PARAMS = "start 40 S ."
-
+DEPENDS = "dtc-native"
RDEPENDS_${PN} = "bash"
@@ -38,9 +38,12 @@ S = "${WORKDIR}/git"
do_compile[depends] += "virtual/kernel:do_deploy virtual/kernel:do_shared_workdir"
do_compile[nostamp] = "1"
+# Make sure we are using the Yocto version of DTC, not what is installed in /usr/bin
+DTC_BIN_DIR = "${COMPONENTS_DIR}/x86_64/dtc-native/usr/bin"
+
do_compile () {
- echo MACHINE is ${MACHINE}
- oe_runmake DTC=/usr/bin/dtc KERNEL_DIR=${STAGING_KERNEL_DIR} KERNEL_BUILD_DIR=${KERNEL_PATH} ${MACHINE}_dtbos
+ echo MACHINE is ${MACHINE}
+ oe_runmake DTC=${DTC_BIN_DIR}/dtc KERNEL_DIR=${STAGING_KERNEL_DIR} KERNEL_BUILD_DIR=${KERNEL_PATH} ${MACHINE}_dtbos
}
FILES_${PN} = "${dt_dir} ${sysconfdir}"