summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2018-10-23 13:22:06 -0500
committerJohn Klug <john.klug@multitech.com>2019-07-03 11:22:01 -0500
commit43214221ff4c5fa71494afda0e913b5730d27f70 (patch)
treec03d1a54f84c0eecf6e5cd91e983fafab736782e
parent18f53bbb76981baf8cf2dd565a7f591af8190997 (diff)
downloadmeta-multitech-43214221ff4c5fa71494afda0e913b5730d27f70.tar.gz
meta-multitech-43214221ff4c5fa71494afda0e913b5730d27f70.tar.bz2
meta-multitech-43214221ff4c5fa71494afda0e913b5730d27f70.zip
Gary Miller-s GPIO PPS Patch
-rw-r--r--recipes-kernel/linux/linux-at91-4.9/linux-4.9-pps-gpio.patch31
-rw-r--r--recipes-kernel/linux/linux-at91_4.9.bb2
2 files changed, 32 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-at91-4.9/linux-4.9-pps-gpio.patch b/recipes-kernel/linux/linux-at91-4.9/linux-4.9-pps-gpio.patch
new file mode 100644
index 0000000..554b53f
--- /dev/null
+++ b/recipes-kernel/linux/linux-at91-4.9/linux-4.9-pps-gpio.patch
@@ -0,0 +1,31 @@
+diff -uprN old/Documentation/devicetree/bindings/pps/pps-gpio.txt new/Documentation/devicetree/bindings/pps/pps-gpio.txt
+--- old/Documentation/devicetree/bindings/pps/pps-gpio.txt 2016-09-19 09:51:11.271472335 -0500
++++ new/Documentation/devicetree/bindings/pps/pps-gpio.txt 2016-09-19 09:49:27.283474197 -0500
+@@ -17,4 +17,5 @@ Example:
+ gpios = <&gpio2 6 0>;
+
+ assert-falling-edge;
++ capture-clear;
+ };
+diff -uprN old/drivers/pps/clients/pps-gpio.c new/drivers/pps/clients/pps-gpio.c
+--- old/drivers/pps/clients/pps-gpio.c 2016-09-19 09:51:11.271472335 -0500
++++ new/drivers/pps/clients/pps-gpio.c 2016-09-19 17:09:02.367001869 -0500
+@@ -119,6 +119,8 @@ static int pps_gpio_probe(struct platfor
+
+ if (of_get_property(np, "assert-falling-edge", NULL))
+ data->assert_falling_edge = true;
++ if (of_get_property(np, "capture-clear", NULL))
++ data->capture_clear = true;
+ }
+
+ /* GPIO setup */
+@@ -208,6 +210,8 @@ static struct platform_driver pps_gpio_d
+ module_platform_driver(pps_gpio_driver);
+ MODULE_AUTHOR("Ricardo Martins <rasm@fe.up.pt>");
+ MODULE_AUTHOR("James Nuss <jamesnuss@nanometrics.ca>");
++MODULE_AUTHOR("Gary Miller <gem@rellim.com>");
++
+ MODULE_DESCRIPTION("Use GPIO pin as PPS source");
+ MODULE_LICENSE("GPL");
+-MODULE_VERSION("1.0.0");
++MODULE_VERSION("1.0.1");
diff --git a/recipes-kernel/linux/linux-at91_4.9.bb b/recipes-kernel/linux/linux-at91_4.9.bb
index 2709f1b..7f62984 100644
--- a/recipes-kernel/linux/linux-at91_4.9.bb
+++ b/recipes-kernel/linux/linux-at91_4.9.bb
@@ -23,7 +23,7 @@ KBRANCH = "linux-4.9-at91"
SRC_URI = "git://github.com/linux4sam/linux-at91.git;protocol=git;branch=${KBRANCH}"
SRC_URI += "file://defconfig"
-COMMON_PATCHES = ""
+COMMON_PATCHES = "file://linux-4.9-pps-gpio.patch"
SRC_URI_append_mtcdt = "\
${COMMON_PATCHES} \