summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Hatch <jhatch@multitech.com>2019-07-29 09:15:17 -0500
committerJeff Hatch <jhatch@multitech.com>2019-07-29 09:15:17 -0500
commitc6271e5ff288a39f5e2ab7ea69a740a117214195 (patch)
tree32205818420ab835f8a5e49ce33a673230ef6b23
parent24a7145714d721a6736817eaf8280545ab7dca63 (diff)
parent74f6b495e5015de01623a53f9c568649fea0d1ac (diff)
downloadmeta-multitech-c6271e5ff288a39f5e2ab7ea69a740a117214195.tar.gz
meta-multitech-c6271e5ff288a39f5e2ab7ea69a740a117214195.tar.bz2
meta-multitech-c6271e5ff288a39f5e2ab7ea69a740a117214195.zip
Merge branch 'master' of gitlab.multitech.net:mirrors/meta-multitech
-rw-r--r--recipes-kernel/linux/linux-at91_4.9.87.bb2
-rw-r--r--recipes-kernel/rs9113/rs9113.inc11
2 files changed, 11 insertions, 2 deletions
diff --git a/recipes-kernel/linux/linux-at91_4.9.87.bb b/recipes-kernel/linux/linux-at91_4.9.87.bb
index 65ebc8d..9d9ba75 100644
--- a/recipes-kernel/linux/linux-at91_4.9.87.bb
+++ b/recipes-kernel/linux/linux-at91_4.9.87.bb
@@ -105,7 +105,7 @@ kernel_do_configure_append() {
KERNEL_MODULE_PACKAGE_SUFFIX=""
-COMPATIBLE_MACHINE = "(mtcdt|mtrv1|mtr|mtcap)"
+COMPATIBLE_MACHINE = "(mtcdt|mtrv1|mtr|mtcap|mths)"
pkg_preinst_kernel-image-uimage() {
set -x
diff --git a/recipes-kernel/rs9113/rs9113.inc b/recipes-kernel/rs9113/rs9113.inc
index 26eeb84..a22dcdf 100644
--- a/recipes-kernel/rs9113/rs9113.inc
+++ b/recipes-kernel/rs9113/rs9113.inc
@@ -8,7 +8,7 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
# noarch contains the init script and configuration for the driver and
# the firmware file (firmware/*.rps).
-PACKAGES = "${PN}-utils-extra ${PN}-misc kernel-module-${PN} ${PN}-util ${PN}-dbg ${PN}-noarch ${PN}-autostart"
+PACKAGES = "${PN}-utils-extra ${PN}-misc kernel-module-${PN} ${PN}-util ${PN}-dbg ${PN}-noarch ${PN}-autostart ${PN}-btclonly"
ALLOW_EMPTY_${PN}-autostart = "1"
PACKAGE_ARCH_${PN}-noarch = "all"
PACKAGE_ARCH_${PN}-misc = "all"
@@ -16,9 +16,12 @@ PACKAGE_ARCH_${PN}-autostart = "all"
PACKAGE_ARCH_${PN}-util = "${TUNE_PKGARCH}"
PACKAGE_ARCH_${PN}-utils-extra = "${TUNE_PKGARCH}"
PACKAGE_ARCH_${PN}-dbg = "${TUNE_PKGARCH}"
+PACKAGE_ARCH_${PN}-btclonly = "all"
RDEPENDS_${PN}-noarch = "bash"
RDEPENDS_${PN}-misc = "bash"
+ALLOW_EMPTY_${PN}-btclonly = "1"
+
DR = "${DL_DIR}/rs9113-ipk"
FILESEXTRAPATHS_append := "${DR}:"
@@ -164,3 +167,9 @@ python do_cleanall_prepend () {
bb.note("About to delete " + DR)
os.system("/bin/rm -rf " + DR)
}
+
+# btclonly package sets Bluetooth Classic mode
+pkg_postinst_${PN}-btclonly() {
+ sed -i 's/^COEX_MODE=.*/COEX_MODE=4/' $D${sysconfdir}/default/rs9113
+}
+