summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Nicholson <Mike.Nicholson@multitech.com>2019-02-27 18:11:34 -0600
committerJohn Klug <john.klug@multitech.com>2019-07-03 11:22:01 -0500
commitd756a673faabf065f0819a4a12a6a01675a9c7e6 (patch)
tree0549257f92969a0ae48c063625b5be459c8641b5
parent68acd9271ba87229acdd489a6006df38bd5b3b53 (diff)
downloadmeta-multitech-d756a673faabf065f0819a4a12a6a01675a9c7e6.tar.gz
meta-multitech-d756a673faabf065f0819a4a12a6a01675a9c7e6.tar.bz2
meta-multitech-d756a673faabf065f0819a4a12a6a01675a9c7e6.zip
Enable/disable murata in wl12xx SDIO driver; deglitch, remove pull-down
on IRQ (to match current production)
-rw-r--r--recipes-kernel/linux/linux-at91-4.9.87/mtr/linux-4.9-mtr-device-tree.patch2
-rw-r--r--recipes-kernel/linux/linux-at91-4.9.87/mtr/wl12xx_enable_disable.patch24
-rw-r--r--recipes-kernel/linux/linux-at91_4.9.87.bb1
3 files changed, 26 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-at91-4.9.87/mtr/linux-4.9-mtr-device-tree.patch b/recipes-kernel/linux/linux-at91-4.9.87/mtr/linux-4.9-mtr-device-tree.patch
index 95e3941..8c076be 100644
--- a/recipes-kernel/linux/linux-at91-4.9.87/mtr/linux-4.9-mtr-device-tree.patch
+++ b/recipes-kernel/linux/linux-at91-4.9.87/mtr/linux-4.9-mtr-device-tree.patch
@@ -75,7 +75,7 @@ diff -Naru linux-4.9.87.orig/arch/arm/boot/dts/mtr.dts linux-4.9.87/arch/arm/boo
+ mmc0 {
+ pinctrl_board_mmc0: mmc0-board {
+ atmel,pins =
-+ <AT91_PIOA 26 AT91_PERIPH_GPIO AT91_PINCTRL_PULL_DOWN /* PA26 gpio A int pin pull down */
++ <AT91_PIOA 26 AT91_PERIPH_GPIO AT91_PINCTRL_DEGLITCH /* PA26 gpio A int pin deglitch (external PU) */
+ AT91_PIOD 15 AT91_PERIPH_GPIO AT91_PINCTRL_PULL_UP_DEGLITCH>; /* PD15 gpio CD pin pull up and deglitch */
+ };
+ };
diff --git a/recipes-kernel/linux/linux-at91-4.9.87/mtr/wl12xx_enable_disable.patch b/recipes-kernel/linux/linux-at91-4.9.87/mtr/wl12xx_enable_disable.patch
new file mode 100644
index 0000000..f9baa14
--- /dev/null
+++ b/recipes-kernel/linux/linux-at91-4.9.87/mtr/wl12xx_enable_disable.patch
@@ -0,0 +1,24 @@
+diff --git a/drivers/net/wireless/ti/wlcore/sdio.c b/drivers/net/wireless/ti/wlcore/sdio.c
+index 47fe7f96..fb209475 100644
+--- a/drivers/net/wireless/ti/wlcore/sdio.c
++++ b/drivers/net/wireless/ti/wlcore/sdio.c
+@@ -154,6 +154,9 @@ static int wl12xx_sdio_power_on(struct wl12xx_sdio_glue *glue)
+ struct sdio_func *func = dev_to_sdio_func(glue->dev);
+ struct mmc_card *card = func->card;
+
++ /* Multi-Tech MTR patch: Assert WL_EN (PA27) to enable Wi-Fi */
++ gpio_set_value(27, 1);
++
+ ret = pm_runtime_get_sync(&card->dev);
+ if (ret) {
+ /*
+@@ -185,6 +188,9 @@ static int wl12xx_sdio_power_off(struct wl12xx_sdio_glue *glue)
+ sdio_claim_host(func);
+ sdio_disable_func(func);
+ sdio_release_host(func);
++
++ /* Multi-Tech MTR patch: De-assert WL_EN (PA27) to disable Wi-Fi */
++ gpio_set_value(27, 0);
+
+ /* Power off the card manually in case it wasn't powered off above */
+ ret = mmc_power_save_host(card->host);
diff --git a/recipes-kernel/linux/linux-at91_4.9.87.bb b/recipes-kernel/linux/linux-at91_4.9.87.bb
index 5358151..cf25638 100644
--- a/recipes-kernel/linux/linux-at91_4.9.87.bb
+++ b/recipes-kernel/linux/linux-at91_4.9.87.bb
@@ -64,6 +64,7 @@ SRC_URI_append_mtr = "\
${COMMON_PATCHES} \
file://linux-4.9-mtr-device-tree.patch \
file://fix-atmel-mci-reg-overloading.patch \
+ file://wl12xx_enable_disable.patch \
"
DTB_APPEND_mtcdt = "mtcdt"