summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Nicholson <Mike.Nicholson@multitech.com>2019-02-13 18:06:12 -0600
committerJohn Klug <john.klug@multitech.com>2019-07-03 11:22:01 -0500
commit47ec6155cd5e0656dc644456a6f43b8327bff456 (patch)
tree0523b5a478f27cf30cb5441b27512e7cce3b412b
parent613205e6a4cf9ddb2ef449cdbb09277f53351c39 (diff)
downloadmeta-multitech-47ec6155cd5e0656dc644456a6f43b8327bff456.tar.gz
meta-multitech-47ec6155cd5e0656dc644456a6f43b8327bff456.tar.bz2
meta-multitech-47ec6155cd5e0656dc644456a6f43b8327bff456.zip
DMA for dbgu on MTCDT, and MTCAP (MTCAP requires testing)
-rw-r--r--recipes-kernel/linux/linux-at91-4.9.87/mtcap/linux-4.9-mtcap-device-tree.patch4
-rw-r--r--recipes-kernel/linux/linux-at91-4.9.87/mtcdt/linux-4.9-mtcdt-device-tree.patch8
2 files changed, 10 insertions, 2 deletions
diff --git a/recipes-kernel/linux/linux-at91-4.9.87/mtcap/linux-4.9-mtcap-device-tree.patch b/recipes-kernel/linux/linux-at91-4.9.87/mtcap/linux-4.9-mtcap-device-tree.patch
index 0173ed0..2735184 100644
--- a/recipes-kernel/linux/linux-at91-4.9.87/mtcap/linux-4.9-mtcap-device-tree.patch
+++ b/recipes-kernel/linux/linux-at91-4.9.87/mtcap/linux-4.9-mtcap-device-tree.patch
@@ -258,7 +258,7 @@ diff -Naru linux-4.9.87.orig/arch/arm/boot/dts/Makefile linux-4.9.87/arch/arm/bo
diff -Naru linux-4.9.87.orig/arch/arm/boot/dts/mtcap.dts linux-4.9.87/arch/arm/boot/dts/mtcap.dts
--- linux-4.9.87.orig/arch/arm/boot/dts/mtcap.dts 1969-12-31 18:00:00.000000000 -0600
+++ linux-4.9.87/arch/arm/boot/dts/mtcap.dts 2019-01-31 18:11:18.651648726 -0600
-@@ -0,0 +1,264 @@
+@@ -0,0 +1,266 @@
+/*
+ * DTS file for Multi-Tech Systems MTCAP Hardware
+ *
@@ -376,6 +376,8 @@ diff -Naru linux-4.9.87.orig/arch/arm/boot/dts/mtcap.dts linux-4.9.87/arch/arm/b
+
+ dbgu: serial@fffff200 {
+ status = "okay";
++ atmel,use-dma-rx;
++ atmel,use-dma-tx;
+ };
+
+ usb2: gadget@f803c000 {
diff --git a/recipes-kernel/linux/linux-at91-4.9.87/mtcdt/linux-4.9-mtcdt-device-tree.patch b/recipes-kernel/linux/linux-at91-4.9.87/mtcdt/linux-4.9-mtcdt-device-tree.patch
index 43ca5eb..5585ba8 100644
--- a/recipes-kernel/linux/linux-at91-4.9.87/mtcdt/linux-4.9-mtcdt-device-tree.patch
+++ b/recipes-kernel/linux/linux-at91-4.9.87/mtcdt/linux-4.9-mtcdt-device-tree.patch
@@ -1,7 +1,7 @@
diff -Naru linux-4.9.87.orig/arch/arm/boot/dts/mtcdt.dts linux-4.9.87/arch/arm/boot/dts/mtcdt.dts
--- linux-4.9.87.orig/arch/arm/boot/dts/mtcdt.dts 1969-12-31 18:00:00.000000000 -0600
+++ linux-4.9.87/arch/arm/boot/dts/mtcdt.dts 2019-01-25 15:44:49.655256032 -0600
-@@ -0,0 +1,254 @@
+@@ -0,0 +1,260 @@
+/*
+ * DTS file for Multi-Tech Systems MTCDT Hardware
+ */
@@ -78,6 +78,12 @@ diff -Naru linux-4.9.87.orig/arch/arm/boot/dts/mtcdt.dts linux-4.9.87/arch/arm/b
+ status = "okay";
+ };
+
++ dbgu: serial@fffff200 {
++ status = "okay";
++ atmel,use-dma-rx;
++ atmel,use-dma-tx;
++ };
++
+ /* runs to Accessory Port 1 */
+ spi0: spi@f0000000 {
+ status = "okay";