summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2019-06-25 09:15:19 -0500
committerJohn Klug <john.klug@multitech.com>2019-07-03 11:22:01 -0500
commit095f3fa2d32a9e870752bbcc89209128ef3fee69 (patch)
treec3ae6eba6ec0abcd6bd8d3cdf795ea5b9b5561cd
parenta4234536babb2395b93f3f3b504c6d2091fe0a6f (diff)
downloadmeta-multitech-095f3fa2d32a9e870752bbcc89209128ef3fee69.tar.gz
meta-multitech-095f3fa2d32a9e870752bbcc89209128ef3fee69.tar.bz2
meta-multitech-095f3fa2d32a9e870752bbcc89209128ef3fee69.zip
btclonly package for rs9113, and mths compatible "machine" for kernel
-rw-r--r--recipes-kernel/linux/linux-at91_4.9.87.bb2
-rw-r--r--recipes-kernel/rs9113/rs9113.inc11
2 files changed, 11 insertions, 2 deletions
diff --git a/recipes-kernel/linux/linux-at91_4.9.87.bb b/recipes-kernel/linux/linux-at91_4.9.87.bb
index 65ebc8d..9d9ba75 100644
--- a/recipes-kernel/linux/linux-at91_4.9.87.bb
+++ b/recipes-kernel/linux/linux-at91_4.9.87.bb
@@ -105,7 +105,7 @@ kernel_do_configure_append() {
KERNEL_MODULE_PACKAGE_SUFFIX=""
-COMPATIBLE_MACHINE = "(mtcdt|mtrv1|mtr|mtcap)"
+COMPATIBLE_MACHINE = "(mtcdt|mtrv1|mtr|mtcap|mths)"
pkg_preinst_kernel-image-uimage() {
set -x
diff --git a/recipes-kernel/rs9113/rs9113.inc b/recipes-kernel/rs9113/rs9113.inc
index 26eeb84..a22dcdf 100644
--- a/recipes-kernel/rs9113/rs9113.inc
+++ b/recipes-kernel/rs9113/rs9113.inc
@@ -8,7 +8,7 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
# noarch contains the init script and configuration for the driver and
# the firmware file (firmware/*.rps).
-PACKAGES = "${PN}-utils-extra ${PN}-misc kernel-module-${PN} ${PN}-util ${PN}-dbg ${PN}-noarch ${PN}-autostart"
+PACKAGES = "${PN}-utils-extra ${PN}-misc kernel-module-${PN} ${PN}-util ${PN}-dbg ${PN}-noarch ${PN}-autostart ${PN}-btclonly"
ALLOW_EMPTY_${PN}-autostart = "1"
PACKAGE_ARCH_${PN}-noarch = "all"
PACKAGE_ARCH_${PN}-misc = "all"
@@ -16,9 +16,12 @@ PACKAGE_ARCH_${PN}-autostart = "all"
PACKAGE_ARCH_${PN}-util = "${TUNE_PKGARCH}"
PACKAGE_ARCH_${PN}-utils-extra = "${TUNE_PKGARCH}"
PACKAGE_ARCH_${PN}-dbg = "${TUNE_PKGARCH}"
+PACKAGE_ARCH_${PN}-btclonly = "all"
RDEPENDS_${PN}-noarch = "bash"
RDEPENDS_${PN}-misc = "bash"
+ALLOW_EMPTY_${PN}-btclonly = "1"
+
DR = "${DL_DIR}/rs9113-ipk"
FILESEXTRAPATHS_append := "${DR}:"
@@ -164,3 +167,9 @@ python do_cleanall_prepend () {
bb.note("About to delete " + DR)
os.system("/bin/rm -rf " + DR)
}
+
+# btclonly package sets Bluetooth Classic mode
+pkg_postinst_${PN}-btclonly() {
+ sed -i 's/^COEX_MODE=.*/COEX_MODE=4/' $D${sysconfdir}/default/rs9113
+}
+