summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2019-04-05 15:34:12 -0500
committerJohn Klug <john.klug@multitech.com>2019-07-03 11:22:01 -0500
commit1721e855f013c77e7e406a8474ef0c64c74b5a56 (patch)
tree72c294645ca85c0f8487879bea39fd095944160d
parent270f36911b18a3f09656a4c218e4b5270811ebf7 (diff)
downloadmeta-multitech-1721e855f013c77e7e406a8474ef0c64c74b5a56.tar.gz
meta-multitech-1721e855f013c77e7e406a8474ef0c64c74b5a56.tar.bz2
meta-multitech-1721e855f013c77e7e406a8474ef0c64c74b5a56.zip
Typo in name of patch for led brightness
-rw-r--r--recipes-bsp/multitech/mts-io.inc2
-rwxr-xr-xrecipes-bsp/multitech/mts-io/mts-io.init5
-rw-r--r--recipes-kernel/linux/linux-at91_4.9.87.bb2
3 files changed, 7 insertions, 2 deletions
diff --git a/recipes-bsp/multitech/mts-io.inc b/recipes-bsp/multitech/mts-io.inc
index 53fa99e..f742ff4 100644
--- a/recipes-bsp/multitech/mts-io.inc
+++ b/recipes-bsp/multitech/mts-io.inc
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://io-module/COPYING;md5=94d55d512a9ba36caa9b7df079bae19
file://io-tool/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
"
DEPENDS = "virtual/kernel"
-INC_PR = "r3"
+INC_PR = "r4"
SRCREV = "${PV}"
diff --git a/recipes-bsp/multitech/mts-io/mts-io.init b/recipes-bsp/multitech/mts-io/mts-io.init
index 336f89e..329a28b 100755
--- a/recipes-bsp/multitech/mts-io/mts-io.init
+++ b/recipes-bsp/multitech/mts-io/mts-io.init
@@ -209,6 +209,11 @@ read_card_info() {
elif [ -d $port2 ] && [[ $(cat $port2/hw-version) = $lora_hw ]]; then
modprobe spidev
ln -sf /dev/spidev32765.2 /dev/spidev0.0
+ elif [[ ${hw_name} == MTCAP ]]; then
+ modprobe spidev
+ elif [[ ${hw_name} == MTCDTIPHP ]]; then
+ modprobe spidev
+ ln -sf /dev/spidev32766.2 /dev/spidev0.0
fi
}
diff --git a/recipes-kernel/linux/linux-at91_4.9.87.bb b/recipes-kernel/linux/linux-at91_4.9.87.bb
index cc7186d..5a1da8d 100644
--- a/recipes-kernel/linux/linux-at91_4.9.87.bb
+++ b/recipes-kernel/linux/linux-at91_4.9.87.bb
@@ -45,7 +45,7 @@ COMMON_PATCHES = " \
file://linux-4.9-telit_print_qmi_wwan.patch \
file://linux-4.9-addl-time-for-pmeccerrloc.patch \
file://950-0090-OF-DT-Overlay-configfs-interface.patch \
- file://led-core-Fix-brightness-setting-when-setting-delay_off-0.patch \
+ file://linux-4.9-led-core-Fix-brightness-setting-when-setting-delay_off-0.patch \
"