summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2018-05-17 18:45:01 -0500
committerJohn Klug <john.klug@multitech.com>2018-05-17 18:45:01 -0500
commit03683f26c87c613a450b936c0d93f96a15ae04fd (patch)
tree686d91490fb0be8edf5b15189916dde990875a58
parent834424c39da43d183e47d724910a7f2027eed5cd (diff)
downloadmeta-multitech-03683f26c87c613a450b936c0d93f96a15ae04fd.tar.gz
meta-multitech-03683f26c87c613a450b936c0d93f96a15ae04fd.tar.bz2
meta-multitech-03683f26c87c613a450b936c0d93f96a15ae04fd.zip
Make rs9113 more MTR friendly.
-rw-r--r--recipes-kernel/rs9113/rs9113.inc5
-rw-r--r--recipes-kernel/rs9113/rs9113_1.6.0.bb3
2 files changed, 5 insertions, 3 deletions
diff --git a/recipes-kernel/rs9113/rs9113.inc b/recipes-kernel/rs9113/rs9113.inc
index 2774b76..de80800 100644
--- a/recipes-kernel/rs9113/rs9113.inc
+++ b/recipes-kernel/rs9113/rs9113.inc
@@ -1,4 +1,5 @@
inherit update-rc.d
+PACKAGE_ARCH = "${MACHINE_ARCH}"
DR = "${DL_DIR}/rs9113-ipk"
FILESEXTRAPATHS_append := "${DR}:"
@@ -17,6 +18,8 @@ python do_fetch_prepend () {
DR = d.getVar("DR",True)
bb.note("DR is " + DR)
+ ARCH = d.getVar("PACKAGE_ARCH",True)
+
try:
os.mkdir(DR,0o755)
except OSError:
@@ -42,7 +45,7 @@ python do_fetch_prepend () {
bb.note("PV is " + PV)
- ipkn = "rs9113-from-src_" + PV + ".0_mtcdt.ipk"
+ ipkn = "rs9113-from-src_" + PV + ".0_" + ARCH + ".ipk"
bb.note("ipkname is " + ipkn)
bb.note ("ipk path is " + DR + "/" + ipkn)
diff --git a/recipes-kernel/rs9113/rs9113_1.6.0.bb b/recipes-kernel/rs9113/rs9113_1.6.0.bb
index 666d06f..5e820e5 100644
--- a/recipes-kernel/rs9113/rs9113_1.6.0.bb
+++ b/recipes-kernel/rs9113/rs9113_1.6.0.bb
@@ -2,7 +2,6 @@ require rs9113.inc
DESCRIPTION = "USB Driver for Redpine RS9113"
LICENSE = "Proprietary"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
-PACKAGE_ARCH = "mtcdt"
PROVIDES = "rs9113"
FILES_${PN} = "/opt/rs9113 ${sbindir} ${sysconfdir}"
RDEPENDS_${PN} += "perl bash"
@@ -21,7 +20,7 @@ SRC_URI = " \
file://rs9113/rs9113.init \
file://rs9113/rs9113.default \
file://rs9113/wpa_supplicant \
- file://rs9113-ipk/rs9113-from-src_${PV}-${PR}.0_mtcdt.ipk;name=binaries \
+ file://rs9113-ipk/rs9113-from-src_${PV}-${PR}.0_${MACHINE}.ipk;name=binaries \
"
SRCREV = "${AUTOREV}"
# For some reason the md5sum and sha256sum are ignored