summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2018-04-20 16:27:27 -0500
committerJohn Klug <john.klug@multitech.com>2018-04-20 16:27:27 -0500
commitcbd128ea60a1d8d348a640235af90a6e3d7232e4 (patch)
tree5a39ff4b827c93a03c87d94ea21fde63e32dcb06
parent5b2c974cd719c7bc4cbab0f786cb68cc698464f4 (diff)
downloadmeta-multitech-cbd128ea60a1d8d348a640235af90a6e3d7232e4.tar.gz
meta-multitech-cbd128ea60a1d8d348a640235af90a6e3d7232e4.tar.bz2
meta-multitech-cbd128ea60a1d8d348a640235af90a6e3d7232e4.zip
Change get-eeprom-device-config to use new mts-io feature.
-rwxr-xr-xrecipes-bsp/multitech/get-eeprom-device-config/get-eeprom-device-config.sh6
-rw-r--r--recipes-bsp/multitech/get-eeprom-device-config_1.2.1.bb (renamed from recipes-bsp/multitech/get-eeprom-device-config_1.2.0.bb)0
2 files changed, 2 insertions, 4 deletions
diff --git a/recipes-bsp/multitech/get-eeprom-device-config/get-eeprom-device-config.sh b/recipes-bsp/multitech/get-eeprom-device-config/get-eeprom-device-config.sh
index b6d9e5f..ab47d31 100755
--- a/recipes-bsp/multitech/get-eeprom-device-config/get-eeprom-device-config.sh
+++ b/recipes-bsp/multitech/get-eeprom-device-config/get-eeprom-device-config.sh
@@ -195,10 +195,8 @@ fi
done <${CONFIG_PATH}/device_info
-PRODUCTID=$(cat /sys/devices/platform/mts-io/product-id)
-# No modem if first hyphen in product-ID is followed by
-# a numeric. Modems always start with an alpha.
-if ((${#PRODUCTID})) && [[ $PRODUCTID =~ ^[^-]+-[^0-9] ]] ; then
+HASRADIO=$(cat /sys/devices/platform/mts-io/has-radio)
+if ((HASRADIO == 1)) ; then
echo "Finding cellular module..."
for ((i=0; i < TRY_COUNT; i++))
do
diff --git a/recipes-bsp/multitech/get-eeprom-device-config_1.2.0.bb b/recipes-bsp/multitech/get-eeprom-device-config_1.2.1.bb
index c2330c3..c2330c3 100644
--- a/recipes-bsp/multitech/get-eeprom-device-config_1.2.0.bb
+++ b/recipes-bsp/multitech/get-eeprom-device-config_1.2.1.bb