summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2016-11-08 16:26:03 -0600
committerJohn Klug <john.klug@multitech.com>2016-11-08 16:26:03 -0600
commit81c19f4bffda530b40b8ae709769da9702090216 (patch)
tree1b1dcaf467a52e198eeba365128643a842345454
parent7e35fa162e883ee2429fbaf49cc8f66ba64d17c9 (diff)
downloadmeta-multitech-81c19f4bffda530b40b8ae709769da9702090216.tar.gz
meta-multitech-81c19f4bffda530b40b8ae709769da9702090216.tar.bz2
meta-multitech-81c19f4bffda530b40b8ae709769da9702090216.zip
New bitbake recipe for rs9113 in the manner of annex client.
-rw-r--r--recipes-kernel/rs9113/rs9113-from-src_1.5.0.bb59
-rw-r--r--recipes-kernel/rs9113/rs9113.bb14
2 files changed, 73 insertions, 0 deletions
diff --git a/recipes-kernel/rs9113/rs9113-from-src_1.5.0.bb b/recipes-kernel/rs9113/rs9113-from-src_1.5.0.bb
new file mode 100644
index 0000000..006bf5b
--- /dev/null
+++ b/recipes-kernel/rs9113/rs9113-from-src_1.5.0.bb
@@ -0,0 +1,59 @@
+DESCRIPTION = "USB Driver for Redpine RS9113"
+DEPENDS = "virtual/kernel"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
+PACKAGE_ARCH = "mtcdt"
+
+SRCREV = "${AUTOREV}"
+
+SRC_URI = " \
+ git://git@${MTS_INTERNAL_GIT}/mlinux/meta-rs9113.git;protocol=ssh;branch=${PV};destsuffix=meta/ \
+ git://git@${MTS_INTERNAL_GIT}/mlinux/Redpine.git;protocol=ssh;branch=${PV} \
+"
+SRCXX_URI = " \
+ git://git@${MTS_INTERNAL_GIT}/mlinux/Redpine.git;protocol=ssh;branch=${PV};name=machine \
+ git://git@${MTS_INTERNAL_GIT}/mlinux/meta-rs9113.git;protocol=ssh;branch=${PV};name=meta \
+"
+
+S = "${WORKDIR}/git/source/host"
+M = "${WORKDIR}/meta"
+
+EXTRA_OEMAKE = " KERNELDIR=${STAGING_KERNEL_DIR} \
+ CROSS_COMPILE=${TARGET_PREFIX} \
+ ARCH=arm \
+ WLAN_COMPILE_FLAGS='' \
+ V=1 \
+ "
+
+inherit update-rc.d
+INITSCRIPT_NAME = "rs9113"
+INITSCRIPT_PARAMS = "start 00 2 3 4 5 . stop 81 0 6 1 ."
+
+FILES_${PN} = "/opt/rs9113 ${sbindir} ${sysconfdir}"
+FILES_${PN}-dbg = "/opt/rs9113/.debug/"
+
+PARALLEL_MAKE = ""
+
+do_configure() {
+ cp ${M}/mtcdt/defconfig .config
+}
+
+do_compile () {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake
+}
+
+do_install() {
+ install -m 0755 -d ${D}/opt/rs9113
+ install -d ${D}${sysconfdir}/init.d/
+ install -d ${D}${sysconfdir}/default/
+ install -d ${D}/opt/rs9113/init.d
+ cp -r ${S}/release/* ${D}/opt/rs9113/
+ rm -rf ${D}/opt/rs9113/flash ${D}/opt/rs9113/certs ${D}/opt/rs9113/*zigb*
+ install -m 0755 -d ${D}${sbindir}
+ install -m 0755 ${M}/rs9113_load_modules.sh ${D}${sbindir}/
+ install -m 0755 ${M}/rs9113_remove_modules.sh ${D}${sbindir}/
+ install -m 0755 ${M}/rs9113.init ${D}${sysconfdir}/init.d/rs9113
+ install -m 0644 ${M}/rs9113.default ${D}${sysconfdir}/default/rs9113
+ install -m 0755 ${M}/wpa_supplicant ${D}/opt/rs9113/init.d
+}
diff --git a/recipes-kernel/rs9113/rs9113.bb b/recipes-kernel/rs9113/rs9113.bb
new file mode 100644
index 0000000..b24bed2
--- /dev/null
+++ b/recipes-kernel/rs9113/rs9113.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Package download of rs9113"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
+PACKAGE_ARCH = "mtcdt"
+PROVIDES = "rs9113"
+
+# NOTE: rs9113 binary is built with Jenkin's job using annex-client-fro3m-src.bb
+# To update this, manually copy ipk from Jenkin's job to .net/downloads/
+PR = "r0"
+SRC_URI = "http://multitech.net/downloads/rs9113-from-src_${PV}-${PR}.0_${TUNE_PKGARCH}.ipk \
+"
+
+SRC_URI[md5sum] = "b17462ba3883df6a06b226b37a523eba"
+SRC_URI[sha256sum] = "be903e7e27ad34832cb8045ef805f4e226aa6e254a3c995c5e61a0a9197a95b0"