summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2016-11-16 13:29:16 -0600
committerJohn Klug <john.klug@multitech.com>2016-11-16 13:29:16 -0600
commit3dd42370f0537bace83adbd21af80c98646aefe4 (patch)
tree9b26c97edb8d6a89bb943609311ecc957feabd61
parent8fa996e48e946c01d5ef0f2540d53cc364c2c907 (diff)
downloadmeta-multitech-3dd42370f0537bace83adbd21af80c98646aefe4.tar.gz
meta-multitech-3dd42370f0537bace83adbd21af80c98646aefe4.tar.bz2
meta-multitech-3dd42370f0537bace83adbd21af80c98646aefe4.zip
Add back in the old rs9113 1.4.3 driver
-rw-r--r--recipes-kernel/rs9113/rs9113-from-src_1.4.3.bb56
-rw-r--r--recipes-kernel/rs9113/rs9113_1.4.3.bb39
2 files changed, 95 insertions, 0 deletions
diff --git a/recipes-kernel/rs9113/rs9113-from-src_1.4.3.bb b/recipes-kernel/rs9113/rs9113-from-src_1.4.3.bb
new file mode 100644
index 0000000..a7f2eee
--- /dev/null
+++ b/recipes-kernel/rs9113/rs9113-from-src_1.4.3.bb
@@ -0,0 +1,56 @@
+DESCRIPTION = "USB Driver for Redpine RS9113"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
+PACKAGE_ARCH = "mtcdt"
+PROVIDES = "rs9113-from-src"
+
+inherit module
+
+SRCREV = "${AUTOREV}"
+
+SRC_URI = " \
+ git://git@${MTS_INTERNAL_GIT}/mlinux/meta-rs9113.git;protocol=ssh;branch=${PV};destsuffix=meta/ \
+ git://git@${MTS_INTERNAL_GIT}/mlinux/Redpine.git;protocol=ssh;branch=${PV} \
+"
+SRCXX_URI = " \
+ git://git@${MTS_INTERNAL_GIT}/mlinux/Redpine.git;protocol=ssh;branch=${PV};name=machine \
+ git://git@${MTS_INTERNAL_GIT}/mlinux/meta-rs9113.git;protocol=ssh;branch=${PV};name=meta \
+"
+
+S = "${WORKDIR}/git/source/host"
+M = "${WORKDIR}/meta"
+
+EXTRA_OEMAKE = " KERNELDIR=${STAGING_KERNEL_DIR} \
+ CROSS_COMPILE=${TARGET_PREFIX} \
+ ARCH=arm \
+ WLAN_COMPILE_FLAGS='' \
+ V=1 \
+ "
+
+inherit update-rc.d
+INITSCRIPT_NAME = "rs9113"
+INITSCRIPT_PARAMS = "start 00 2 3 4 5 . stop 81 0 6 1 ."
+
+FILES_${PN} = "/opt/rs9113 ${sbindir}"
+FILES_${PN}-dbg = "/opt/rs9113/.debug/"
+
+PARALLEL_MAKE = ""
+
+do_configure() {
+ cp ${M}/mtcdt/defconfig .config
+}
+
+do_compile () {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake
+}
+
+do_install() {
+ install -m 0755 -d ${D}/opt/rs9113
+ cp -r ${S}/release/* ${D}/opt/rs9113/
+ rm -rf ${D}/opt/rs9113/flash ${D}/opt/rs9113/certs ${D}/opt/rs9113/*zigb*
+ install -m 0755 -d ${D}${sbindir}
+ install -m 0755 ${M}/rs9113_load_modules.sh ${D}${sbindir}/
+ install -m 0755 ${M}/rs9113_remove_modules.sh ${D}${sbindir}/
+}
+
diff --git a/recipes-kernel/rs9113/rs9113_1.4.3.bb b/recipes-kernel/rs9113/rs9113_1.4.3.bb
new file mode 100644
index 0000000..a2f28c9
--- /dev/null
+++ b/recipes-kernel/rs9113/rs9113_1.4.3.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "USB Driver for Redpine RS9113"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
+PACKAGE_ARCH = "mtcdt"
+PROVIDES = "rs9113"
+FILES_${PN} = "/opt/rs9113 ${sbindir} ${sysconfdir}"
+# BB_STRICT_CHECKSUM = "0"
+
+# NOTE: annex-client binary is built with Jenkin's job using annex-client-from-src.bb
+# To update this, manually copy ipk from Jenkin's job to .net/downloads/
+PR = "r0"
+SRC_URI = "http://akbar:8080/job/rs9113/lastSuccessfulBuild/artifact/mlinux/build/tmp/deploy/ipk/mtcdt/rs9113-from-src_${PV}-${PR}.0_${PACKAGE_ARCH}.ipk \
+ file://rs9113/rs9113.init \
+ file://rs9113/rs9113.default \
+ file://rs9113/wpa_supplicant \
+"
+
+M = "${WORKDIR}/rs9113"
+
+python do_fetch_prepend () {
+ d.setVar('BB_STRICT_CHECKSUM',False)
+}
+
+do_install() {
+ bbnote "pwd,ls: $(pwd) $(ls) WORKDIR is ${WORKDIR}"
+ (
+ cd ${WORKDIR}
+ find etc -print0 | cpio -0 -pdum ${D}
+ find usr -print0 | cpio -0 -pdum ${D}
+ find opt -print0 | cpio -0 -pdum ${D}
+ )
+ install -d ${D}/opt/rs9113/init.d
+ install -d ${D}${sysconfdir}/init.d/
+ install -d ${D}${sysconfdir}/default/
+ install -m 0755 ${M}/wpa_supplicant ${D}/opt/rs9113/init.d
+ install -m 0755 ${M}/rs9113.init ${D}${sysconfdir}/init.d/rs9113
+ install -m 0644 ${M}/rs9113.default ${D}${sysconfdir}/default/rs9113
+}
+