summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Reiss <jreiss@multitech.com>2016-12-12 09:38:29 -0600
committerJason Reiss <jreiss@multitech.com>2016-12-12 09:38:29 -0600
commit20445efa8a771c745a478c83e5937793411170a9 (patch)
tree196e0ed7ab111c919d2e2b930c8e33d6b7496d2f
parentdb379a7467b77a41645e83cba9a1e409b0b075d4 (diff)
parentb92c7d6e54763852bd8783745b923c14e9cfda9a (diff)
downloadmeta-multitech-20445efa8a771c745a478c83e5937793411170a9.tar.gz
meta-multitech-20445efa8a771c745a478c83e5937793411170a9.tar.bz2
meta-multitech-20445efa8a771c745a478c83e5937793411170a9.zip
Merge branch 'master' of gitlab.multitech.net:mirrors/meta-multitech
-rw-r--r--recipes-kernel/linux/linux-3.12.27/mtcdt/defconfig4
-rw-r--r--recipes-kernel/rs9113/rs9113.inc59
-rw-r--r--recipes-kernel/rs9113/rs9113_1.4.3.bb68
-rw-r--r--recipes-kernel/rs9113/rs9113_1.5.0.bb68
4 files changed, 69 insertions, 130 deletions
diff --git a/recipes-kernel/linux/linux-3.12.27/mtcdt/defconfig b/recipes-kernel/linux/linux-3.12.27/mtcdt/defconfig
index 789e890..028f41d 100644
--- a/recipes-kernel/linux/linux-3.12.27/mtcdt/defconfig
+++ b/recipes-kernel/linux/linux-3.12.27/mtcdt/defconfig
@@ -616,7 +616,7 @@ CONFIG_NETFILTER_XT_TARGET_HL=m
# CONFIG_NETFILTER_XT_TARGET_HMARK is not set
# CONFIG_NETFILTER_XT_TARGET_IDLETIMER is not set
# CONFIG_NETFILTER_XT_TARGET_LED is not set
-# CONFIG_NETFILTER_XT_TARGET_LOG is not set
+CONFIG_NETFILTER_XT_TARGET_LOG=y
CONFIG_NETFILTER_XT_TARGET_MARK=y
CONFIG_NETFILTER_XT_TARGET_NETMAP=y
# CONFIG_NETFILTER_XT_TARGET_NFLOG is not set
@@ -648,7 +648,7 @@ CONFIG_NETFILTER_XT_MATCH_CONNTRACK=y
# CONFIG_NETFILTER_XT_MATCH_DSCP is not set
CONFIG_NETFILTER_XT_MATCH_ECN=y
# CONFIG_NETFILTER_XT_MATCH_ESP is not set
-# CONFIG_NETFILTER_XT_MATCH_HASHLIMIT is not set
+CONFIG_NETFILTER_XT_MATCH_HASHLIMIT=y
# CONFIG_NETFILTER_XT_MATCH_HELPER is not set
CONFIG_NETFILTER_XT_MATCH_HL=y
# CONFIG_NETFILTER_XT_MATCH_IPRANGE is not set
diff --git a/recipes-kernel/rs9113/rs9113.inc b/recipes-kernel/rs9113/rs9113.inc
new file mode 100644
index 0000000..e4dbb2c
--- /dev/null
+++ b/recipes-kernel/rs9113/rs9113.inc
@@ -0,0 +1,59 @@
+DR = "${DL_DIR}/rs9113-ipk"
+
+python do_fetch_prepend () {
+ d.setVar('BB_STRICT_CHECKSUM',False)
+ DR = d.getVar("DR",True)
+ bb.note("DR is " + DR)
+
+ try:
+ os.mkdir(DR,0755)
+ except OSError:
+ pass
+ try:
+ ex = "export SSH_AUTH_SOCK=" + d.getVar("SSH_AUTH_SOCK",True)
+ except TypeError:
+ ex=":"
+ bb.note("SSH_AUTH_SOCK not set. SSH keys must not use a pass phrase")
+ bb.note("export is " + ex)
+
+ gt = "git archive -v --remote=git@"
+ try:
+ gt += d.getVar("MTS_INTERNAL_GIT")
+ except TypeError:
+ bb.fatal("MTS_INTERNAL_GIT must be in BB_ENV_EXTRAWHITE")
+
+ PV = d.getVar("PV",True)
+ bb.note("PV is " + PV)
+ gt += ":mlinux/ipk.git " + PV
+ bb.note("git is " + gt)
+ PR = d.getVar("PR",True)
+ tar = "tar -vx --strip-components 1 -C " + DR + " rs9113/rs9113-from-src_"
+ tar += PV + "-" + PR + ".0_mtcdt.ipk"
+ bb.note("tar is " + tar)
+ os.system(ex + ";" + gt + "|" + tar)
+}
+
+MR = "${WORKDIR}/rs9113"
+do_install () {
+ bbnote "pwd,ls: $(pwd) $(ls) WORKDIR is ${WORKDIR}"
+ (
+ cd ${WORKDIR}
+ find etc -print0 | cpio -0 -pdum ${D}
+ find usr -print0 | cpio -0 -pdum ${D}
+ find opt -print0 | cpio -0 -pdum ${D}
+ )
+ install -d ${D}/opt/rs9113/init.d
+ install -d ${D}${sysconfdir}/init.d/
+ install -d ${D}${sysconfdir}/default/
+ install -m 0755 ${MR}/wpa_supplicant ${D}/opt/rs9113/init.d
+ install -m 0755 ${MR}/rs9113.init ${D}${sysconfdir}/init.d/rs9113
+ install -m 0644 ${MR}/rs9113.default ${D}${sysconfdir}/default/rs9113
+}
+
+python do_cleanall_prepend () {
+ bb.note("In do_clean_prepend")
+ DR = d.getVar("DR",True)
+ bb.note("About to delete " + DR)
+ os.system("/bin/rm -rf " + DR)
+}
+
diff --git a/recipes-kernel/rs9113/rs9113_1.4.3.bb b/recipes-kernel/rs9113/rs9113_1.4.3.bb
index 38f25d7..04d00a6 100644
--- a/recipes-kernel/rs9113/rs9113_1.4.3.bb
+++ b/recipes-kernel/rs9113/rs9113_1.4.3.bb
@@ -1,3 +1,4 @@
+require rs9113.inc
DESCRIPTION = "USB Driver for Redpine RS9113"
LICENSE = "Proprietary"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
@@ -6,8 +7,9 @@ PROVIDES = "rs9113"
FILES_${PN} = "/opt/rs9113 ${sbindir} ${sysconfdir}"
# BB_STRICT_CHECKSUM = "0"
-# This bitbake recipe requires SSH_AUTH_SOCK to be set. This is normally done
-# by a keyserver, such as gnome-keyring-daemon or ssh-keyagent.
+# This bitbake recipe requires SSH_AUTH_SOCK to be set if ssh key pass
+# phrases are used. SSH_AUTH_SOCK is set by a keyserver,
+# such as gnome-keyring-daemon or ssh-keyagent.
# NOTE: rs9113 binary is built with Jenkin's job using rs9113-from-src_${PV}.bb
# To update this, manually copy ipk from Jenkin's job to
@@ -20,66 +22,4 @@ SRC_URI = " \
file://rs9113/wpa_supplicant \
file://rs9113-ipk/rs9113-from-src_${PV}-${PR}.0_mtcdt.ipk \
"
-# file://rs9113/rs9113-from-src_${PV}-${PR}.0_mtcdt.ipk
-
SRCREV = "${AUTOREV}"
-
-DR = "${DL_DIR}/rs9113-ipk"
-
-# os.system("export SSH_AUTH_SOCK=${SSH_AUTH_SOCK};git archive --remote=git@${MTS_INTERNAL_GIT}:mlinux/ipk.git ${PV} | tar -x -C ${WORKDIR} rs9113/rs9113-from-src_${PV}-${PR}.0_mtcdt.ipk")
-python do_fetch_prepend () {
- d.setVar('BB_STRICT_CHECKSUM',False)
- DR = d.getVar("DR",True)
- bb.note("DR is " + DR)
-
- try:
- os.mkdir(DR,0755)
- except OSError:
- pass
- ex = "export SSH_AUTH_SOCK=" + d.getVar("SSH_AUTH_SOCK",True)
- bb.note("export is " + ex)
-
- gt = "git archive -v --remote=git@"
- try:
- gt += d.getVar("MTS_INTERNAL_GIT")
- except TypeError:
- bb.fatal("MTS_INTERNAL_GIT must be in BB_ENV_EXTRAWHITE")
-
- PV = d.getVar("PV",True)
- bb.note("PV is " + PV)
- gt += ":mlinux/ipk.git " + PV
- bb.note("git is " + gt)
- PR = d.getVar("PR",True)
- tar = "tar -vx --strip-components 1 -C " + DR + " rs9113/rs9113-from-src_"
- tar += PV + "-" + PR + ".0_mtcdt.ipk"
- bb.note("tar is " + tar)
- os.system(ex + ";" + gt + "|" + tar)
-}
-
-MR = "${WORKDIR}/rs9113"
-do_install () {
- bbnote "pwd,ls: $(pwd) $(ls) WORKDIR is ${WORKDIR}"
- (
- cd ${WORKDIR}
- find etc -print0 | cpio -0 -pdum ${D}
- find usr -print0 | cpio -0 -pdum ${D}
- find opt -print0 | cpio -0 -pdum ${D}
- )
- install -d ${D}/opt/rs9113/init.d
- install -d ${D}${sysconfdir}/init.d/
- install -d ${D}${sysconfdir}/default/
- install -m 0755 ${MR}/wpa_supplicant ${D}/opt/rs9113/init.d
- install -m 0755 ${MR}/rs9113.init ${D}${sysconfdir}/init.d/rs9113
- install -m 0644 ${MR}/rs9113.default ${D}${sysconfdir}/default/rs9113
-}
-
-# echo rm -f ${M}/rs9113-from-src_${PV}-${PR}.0_mtcdt.ipk
-python do_cleanall_prepend () {
- bb.note("In do_clean_prepend")
- DR = d.getVar("DR",True)
- bb.note("About to delete " + DR)
- os.system("/bin/rm -rf " + DR)
-}
-#
-#
-
diff --git a/recipes-kernel/rs9113/rs9113_1.5.0.bb b/recipes-kernel/rs9113/rs9113_1.5.0.bb
index 38f25d7..04d00a6 100644
--- a/recipes-kernel/rs9113/rs9113_1.5.0.bb
+++ b/recipes-kernel/rs9113/rs9113_1.5.0.bb
@@ -1,3 +1,4 @@
+require rs9113.inc
DESCRIPTION = "USB Driver for Redpine RS9113"
LICENSE = "Proprietary"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
@@ -6,8 +7,9 @@ PROVIDES = "rs9113"
FILES_${PN} = "/opt/rs9113 ${sbindir} ${sysconfdir}"
# BB_STRICT_CHECKSUM = "0"
-# This bitbake recipe requires SSH_AUTH_SOCK to be set. This is normally done
-# by a keyserver, such as gnome-keyring-daemon or ssh-keyagent.
+# This bitbake recipe requires SSH_AUTH_SOCK to be set if ssh key pass
+# phrases are used. SSH_AUTH_SOCK is set by a keyserver,
+# such as gnome-keyring-daemon or ssh-keyagent.
# NOTE: rs9113 binary is built with Jenkin's job using rs9113-from-src_${PV}.bb
# To update this, manually copy ipk from Jenkin's job to
@@ -20,66 +22,4 @@ SRC_URI = " \
file://rs9113/wpa_supplicant \
file://rs9113-ipk/rs9113-from-src_${PV}-${PR}.0_mtcdt.ipk \
"
-# file://rs9113/rs9113-from-src_${PV}-${PR}.0_mtcdt.ipk
-
SRCREV = "${AUTOREV}"
-
-DR = "${DL_DIR}/rs9113-ipk"
-
-# os.system("export SSH_AUTH_SOCK=${SSH_AUTH_SOCK};git archive --remote=git@${MTS_INTERNAL_GIT}:mlinux/ipk.git ${PV} | tar -x -C ${WORKDIR} rs9113/rs9113-from-src_${PV}-${PR}.0_mtcdt.ipk")
-python do_fetch_prepend () {
- d.setVar('BB_STRICT_CHECKSUM',False)
- DR = d.getVar("DR",True)
- bb.note("DR is " + DR)
-
- try:
- os.mkdir(DR,0755)
- except OSError:
- pass
- ex = "export SSH_AUTH_SOCK=" + d.getVar("SSH_AUTH_SOCK",True)
- bb.note("export is " + ex)
-
- gt = "git archive -v --remote=git@"
- try:
- gt += d.getVar("MTS_INTERNAL_GIT")
- except TypeError:
- bb.fatal("MTS_INTERNAL_GIT must be in BB_ENV_EXTRAWHITE")
-
- PV = d.getVar("PV",True)
- bb.note("PV is " + PV)
- gt += ":mlinux/ipk.git " + PV
- bb.note("git is " + gt)
- PR = d.getVar("PR",True)
- tar = "tar -vx --strip-components 1 -C " + DR + " rs9113/rs9113-from-src_"
- tar += PV + "-" + PR + ".0_mtcdt.ipk"
- bb.note("tar is " + tar)
- os.system(ex + ";" + gt + "|" + tar)
-}
-
-MR = "${WORKDIR}/rs9113"
-do_install () {
- bbnote "pwd,ls: $(pwd) $(ls) WORKDIR is ${WORKDIR}"
- (
- cd ${WORKDIR}
- find etc -print0 | cpio -0 -pdum ${D}
- find usr -print0 | cpio -0 -pdum ${D}
- find opt -print0 | cpio -0 -pdum ${D}
- )
- install -d ${D}/opt/rs9113/init.d
- install -d ${D}${sysconfdir}/init.d/
- install -d ${D}${sysconfdir}/default/
- install -m 0755 ${MR}/wpa_supplicant ${D}/opt/rs9113/init.d
- install -m 0755 ${MR}/rs9113.init ${D}${sysconfdir}/init.d/rs9113
- install -m 0644 ${MR}/rs9113.default ${D}${sysconfdir}/default/rs9113
-}
-
-# echo rm -f ${M}/rs9113-from-src_${PV}-${PR}.0_mtcdt.ipk
-python do_cleanall_prepend () {
- bb.note("In do_clean_prepend")
- DR = d.getVar("DR",True)
- bb.note("About to delete " + DR)
- os.system("/bin/rm -rf " + DR)
-}
-#
-#
-