summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2017-11-02 16:01:01 -0500
committerJohn Klug <john.klug@multitech.com>2017-11-02 16:01:01 -0500
commit97271322c01c813cf3c3c4a1834637a2d59975ba (patch)
tree07973c42b4facb8696ed2680c93b4ebf13a26c80
parentd145d1e8f9bb906d4e5c10df1600b1428b1dc0d2 (diff)
downloadmeta-multitech-97271322c01c813cf3c3c4a1834637a2d59975ba.tar.gz
meta-multitech-97271322c01c813cf3c3c4a1834637a2d59975ba.tar.bz2
meta-multitech-97271322c01c813cf3c3c4a1834637a2d59975ba.zip
1.5.6 driver for mLinux 33.3.17
-rw-r--r--recipes-kernel/rs9113/rs9113-from-src_1.5.6.bb (renamed from recipes-kernel/rs9113/rs9113-from-src_1.5.0.bb)13
-rw-r--r--recipes-kernel/rs9113/rs9113_1.5.6.bb (renamed from recipes-kernel/rs9113/rs9113_1.5.0.bb)0
2 files changed, 10 insertions, 3 deletions
diff --git a/recipes-kernel/rs9113/rs9113-from-src_1.5.0.bb b/recipes-kernel/rs9113/rs9113-from-src_1.5.6.bb
index 234d6c9..c490ae1 100644
--- a/recipes-kernel/rs9113/rs9113-from-src_1.5.0.bb
+++ b/recipes-kernel/rs9113/rs9113-from-src_1.5.6.bb
@@ -44,10 +44,17 @@ do_compile () {
do_patch () {
cd ${WORKDIR}/git
- echo "patches" ${M}/patches/*
for f in ${M}/patches/* ; do
- echo "Patching with ${f}"
- patch -p1 < ${f}
+ # Cannot use [[ $f =~ \.patch$ ]] here because the $ after patch breaks the recipe.
+ if echo ${f} | grep '\.patch$' >/dev/null 2>&1 ; then
+ echo found patch ${f}
+ patch -Np1 < ${f}
+ else
+ fname=$(basename ${f})
+ oldf=$(find . -name ${fname})
+ echo "copying $f to ${oldf}"
+ cp ${f} ${oldf}
+ fi
done
}
diff --git a/recipes-kernel/rs9113/rs9113_1.5.0.bb b/recipes-kernel/rs9113/rs9113_1.5.6.bb
index fbfb706..fbfb706 100644
--- a/recipes-kernel/rs9113/rs9113_1.5.0.bb
+++ b/recipes-kernel/rs9113/rs9113_1.5.6.bb