summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2016-11-28 11:41:18 -0600
committerJohn Klug <john.klug@multitech.com>2016-11-28 11:41:18 -0600
commit05566a250923246b118d21d3f70d52b20d37a684 (patch)
treec64d2c19ef9051c2485e673ff7a629cfb900aaf9
parentd6492692e037753d75bf6a44229dbe63477cfdde (diff)
downloadmeta-multitech-05566a250923246b118d21d3f70d52b20d37a684.tar.gz
meta-multitech-05566a250923246b118d21d3f70d52b20d37a684.tar.bz2
meta-multitech-05566a250923246b118d21d3f70d52b20d37a684.zip
Build rs9113 1.4.3 from gitlab rs9113-ipk project
-rw-r--r--recipes-kernel/rs9113/rs9113_1.4.3.bb55
1 files changed, 49 insertions, 6 deletions
diff --git a/recipes-kernel/rs9113/rs9113_1.4.3.bb b/recipes-kernel/rs9113/rs9113_1.4.3.bb
index a2f28c9..98bd1eb 100644
--- a/recipes-kernel/rs9113/rs9113_1.4.3.bb
+++ b/recipes-kernel/rs9113/rs9113_1.4.3.bb
@@ -8,20 +8,53 @@ FILES_${PN} = "/opt/rs9113 ${sbindir} ${sysconfdir}"
# NOTE: annex-client binary is built with Jenkin's job using annex-client-from-src.bb
# To update this, manually copy ipk from Jenkin's job to .net/downloads/
+# git://git@${MTS_INTERNAL_GIT}/mlinux/ipk.git;protocol=ssh;branch=${PV}
+#
PR = "r0"
-SRC_URI = "http://akbar:8080/job/rs9113/lastSuccessfulBuild/artifact/mlinux/build/tmp/deploy/ipk/mtcdt/rs9113-from-src_${PV}-${PR}.0_${PACKAGE_ARCH}.ipk \
+SRC_URI = " \
file://rs9113/rs9113.init \
file://rs9113/rs9113.default \
file://rs9113/wpa_supplicant \
+ file://rs9113-ipk/rs9113-from-src_${PV}-${PR}.0_mtcdt.ipk \
"
+# file://rs9113/rs9113-from-src_${PV}-${PR}.0_mtcdt.ipk
-M = "${WORKDIR}/rs9113"
+SRCREV = "${AUTOREV}"
+DR = "${DL_DIR}/rs9113-ipk"
+
+# os.system("export SSH_AUTH_SOCK=${SSH_AUTH_SOCK};git archive --remote=git@${MTS_INTERNAL_GIT}:mlinux/ipk.git ${PV} | tar -x -C ${WORKDIR} rs9113/rs9113-from-src_${PV}-${PR}.0_mtcdt.ipk")
python do_fetch_prepend () {
d.setVar('BB_STRICT_CHECKSUM',False)
+ DR = d.getVar("DR",True)
+ bb.note("DR is " + DR)
+
+ try:
+ os.mkdir(DR,0755)
+ except OSError:
+ pass
+ ex = "export SSH_AUTH_SOCK=" + d.getVar("SSH_AUTH_SOCK",True)
+ bb.note("export is " + ex)
+
+ gt = "git archive -v --remote=git@"
+ try:
+ gt += d.getVar("MTS_INTERNAL_GIT")
+ except TypeError:
+ bb.fatal("MTS_INTERNAL_GIT must be in BB_ENV_EXTRAWHITE")
+
+ PV = d.getVar("PV",True)
+ bb.note("PV is " + PV)
+ gt += ":mlinux/ipk.git " + PV
+ bb.note("git is " + gt)
+ PR = d.getVar("PR",True)
+ tar = "tar -vx --strip-components 1 -C " + DR + " rs9113/rs9113-from-src_"
+ tar += PV + "-" + PR + ".0_mtcdt.ipk"
+ bb.note("tar is " + tar)
+ os.system(ex + ";" + gt + "|" + tar)
}
-do_install() {
+MR = "${WORKDIR}/rs9113"
+do_install () {
bbnote "pwd,ls: $(pwd) $(ls) WORKDIR is ${WORKDIR}"
(
cd ${WORKDIR}
@@ -32,8 +65,18 @@ do_install() {
install -d ${D}/opt/rs9113/init.d
install -d ${D}${sysconfdir}/init.d/
install -d ${D}${sysconfdir}/default/
- install -m 0755 ${M}/wpa_supplicant ${D}/opt/rs9113/init.d
- install -m 0755 ${M}/rs9113.init ${D}${sysconfdir}/init.d/rs9113
- install -m 0644 ${M}/rs9113.default ${D}${sysconfdir}/default/rs9113
+ install -m 0755 ${MR}/wpa_supplicant ${D}/opt/rs9113/init.d
+ install -m 0755 ${MR}/rs9113.init ${D}${sysconfdir}/init.d/rs9113
+ install -m 0644 ${MR}/rs9113.default ${D}${sysconfdir}/default/rs9113
+}
+
+# echo rm -f ${M}/rs9113-from-src_${PV}-${PR}.0_mtcdt.ipk
+python do_cleanall_prepend () {
+ bb.note("In do_clean_prepend")
+ DR = d.getVar("DR",True)
+ bb.note("About to delete " + DR)
+ os.system("/bin/rm -rf " + DR)
}
+#
+#