summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2017-11-02 16:01:01 -0500
committerJohn Klug <john.klug@multitech.com>2018-03-01 12:20:29 -0600
commit21ad0c79ceadedec4c7c2f702c5cea8cb2a96693 (patch)
tree07973c42b4facb8696ed2680c93b4ebf13a26c80
parent8259a1f358d1d6d27bb29fab8ec5a0f09b37ef22 (diff)
downloadmeta-multitech-21ad0c79ceadedec4c7c2f702c5cea8cb2a96693.tar.gz
meta-multitech-21ad0c79ceadedec4c7c2f702c5cea8cb2a96693.tar.bz2
meta-multitech-21ad0c79ceadedec4c7c2f702c5cea8cb2a96693.zip
1.5.6 driver for mLinux 3
-rw-r--r--recipes-kernel/rs9113/rs9113-from-src_1.5.6.bb (renamed from recipes-kernel/rs9113/rs9113-from-src_1.5.0.bb)13
-rw-r--r--recipes-kernel/rs9113/rs9113_1.5.6.bb (renamed from recipes-kernel/rs9113/rs9113_1.5.0.bb)0
2 files changed, 10 insertions, 3 deletions
diff --git a/recipes-kernel/rs9113/rs9113-from-src_1.5.0.bb b/recipes-kernel/rs9113/rs9113-from-src_1.5.6.bb
index 234d6c9..c490ae1 100644
--- a/recipes-kernel/rs9113/rs9113-from-src_1.5.0.bb
+++ b/recipes-kernel/rs9113/rs9113-from-src_1.5.6.bb
@@ -44,10 +44,17 @@ do_compile () {
do_patch () {
cd ${WORKDIR}/git
- echo "patches" ${M}/patches/*
for f in ${M}/patches/* ; do
- echo "Patching with ${f}"
- patch -p1 < ${f}
+ # Cannot use [[ $f =~ \.patch$ ]] here because the $ after patch breaks the recipe.
+ if echo ${f} | grep '\.patch$' >/dev/null 2>&1 ; then
+ echo found patch ${f}
+ patch -Np1 < ${f}
+ else
+ fname=$(basename ${f})
+ oldf=$(find . -name ${fname})
+ echo "copying $f to ${oldf}"
+ cp ${f} ${oldf}
+ fi
done
}
diff --git a/recipes-kernel/rs9113/rs9113_1.5.0.bb b/recipes-kernel/rs9113/rs9113_1.5.6.bb
index fbfb706..fbfb706 100644
--- a/recipes-kernel/rs9113/rs9113_1.5.0.bb
+++ b/recipes-kernel/rs9113/rs9113_1.5.6.bb