summaryrefslogtreecommitdiff
path: root/recipes-kernel/rsi-91x/files/rsi-bt91x-config.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/rsi-91x/files/rsi-bt91x-config.patch')
-rw-r--r--recipes-kernel/rsi-91x/files/rsi-bt91x-config.patch16
1 files changed, 9 insertions, 7 deletions
diff --git a/recipes-kernel/rsi-91x/files/rsi-bt91x-config.patch b/recipes-kernel/rsi-91x/files/rsi-bt91x-config.patch
index 3bda909..3f74f50 100644
--- a/recipes-kernel/rsi-91x/files/rsi-bt91x-config.patch
+++ b/recipes-kernel/rsi-91x/files/rsi-bt91x-config.patch
@@ -1,8 +1,8 @@
diff --git a/rsi/Makefile b/rsi/Makefile
-index 64f7742..bc088b8 100644
+index 0c610f8..7af43f7 100644
--- a/rsi/Makefile
+++ b/rsi/Makefile
-@@ -42,7 +42,7 @@ KERNELDIR=/lib/modules/$(KERNELRELEASE)/build
+@@ -14,7 +14,7 @@ KERNELDIR=/lib/modules/$(KERNELRELEASE)/build
#CONFIG_SDIO_INTR_POLL=y
# Uncomment below line for BT alone (Classic/LE/Dual) mode
@@ -11,7 +11,7 @@ index 64f7742..bc088b8 100644
# Uncomment below line for Wi-Fi BT coex mode
#CONFIG_RSI_COEX_MODE=y
-@@ -190,16 +190,21 @@ ifeq ($(OFFLOAD_SCAN_TO_DEVICE), y)
+@@ -162,19 +162,24 @@ ifeq ($(OFFLOAD_SCAN_TO_DEVICE), y)
EXTRA_CFLAGS += -DOFFLOAD_SCAN_TO_DEVICE
endif
@@ -29,13 +29,15 @@ index 64f7742..bc088b8 100644
+ env
@echo -e "\033[32mCompiling RSI drivers...\033[0m"
make -C$(KERNELDIR)/ M=$(PWD) modules
-- @echo -e "application compilation"
+ chmod 777 start_rs9116.sh
+ chmod 777 osd_common_insert.sh
- make CC="$(CC)" ROOT_DIR=$(ROOT_DIR) -C $(PWD)/apps
-+ # @echo -e "application compilation"
+ # make CC="$(CC)" ROOT_DIR=$(ROOT_DIR) -C $(PWD)/apps
-+
+ @echo -e "\033[32mCompilation done SUCCESSFULLY\033[0m"
+
+modules_install:
+ $(MAKE) -C $(KERNELDIR) M=$(PWD) modules_install
-
++
clean:
make -C$(KERNELDIR)/ M=$(PWD) clean
+ @find . -name 'receive' | xargs rm -rf