summaryrefslogtreecommitdiff
path: root/recipes-kernel/rs9113/rs9113-from-src_1.6.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/rs9113/rs9113-from-src_1.6.5.bb')
-rw-r--r--recipes-kernel/rs9113/rs9113-from-src_1.6.5.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/recipes-kernel/rs9113/rs9113-from-src_1.6.5.bb b/recipes-kernel/rs9113/rs9113-from-src_1.6.5.bb
index 05ba21a..30ade9e 100644
--- a/recipes-kernel/rs9113/rs9113-from-src_1.6.5.bb
+++ b/recipes-kernel/rs9113/rs9113-from-src_1.6.5.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "USB Driver for Redpine RS9113"
LICENSE = "Proprietary"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
PROVIDES = "rs9113-from-src"
-PR = "r10${KERNEL_MODULE_PACKAGE_SUFFIX}"
+PR = "r11${KERNEL_MODULE_PACKAGE_SUFFIX}"
INHIBIT_PACKAGE_STRIP = "1"
BB_STRICT_CHECKSUM = "0"
inherit module
@@ -15,6 +15,8 @@ SRCREV_FORMAT = "machine"
SRC_URI = " \
git://git@${MTS_INTERNAL_GIT}/mlinux/meta-rs9113.git;protocol=ssh;branch=${PV};destsuffix=meta/ \
git://git@${MTS_INTERNAL_GIT}/mlinux/Redpine.git;protocol=ssh;branch=${PV} \
+ file://debug-rs9113.patch \
+ file://onebox-backlog-counter.patch \
"
SRCXX_URI = " \
git://git@${MTS_INTERNAL_GIT}/mlinux/Redpine.git;protocol=ssh;branch=${PV};name=machine \
@@ -56,7 +58,7 @@ do_compile () {
do_patch () {
cd ${WORKDIR}/git
- for f in ${M}/patches/* ; do
+ for f in ${M}/patches/* ../*.patch ; do
# Cannot use [[ $f =~ \.patch$ ]] here because the $ after patch breaks the recipe.
if echo ${f} | grep '\.patch$' >/dev/null 2>&1 ; then
echo found patch ${f}