summaryrefslogtreecommitdiff
path: root/recipes-kernel/linux/linux-at91_4.9.87.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-at91_4.9.87.bb')
-rw-r--r--recipes-kernel/linux/linux-at91_4.9.87.bb15
1 files changed, 11 insertions, 4 deletions
diff --git a/recipes-kernel/linux/linux-at91_4.9.87.bb b/recipes-kernel/linux/linux-at91_4.9.87.bb
index 4f035b5..7fc0e5d 100644
--- a/recipes-kernel/linux/linux-at91_4.9.87.bb
+++ b/recipes-kernel/linux/linux-at91_4.9.87.bb
@@ -19,7 +19,7 @@ RDEPENDS_kernel-modules_remove = "kernel-module-softdog"
FILESEXTRAPATHS_prepend := "${THISDIR}/${P}:"
KERNEL_EXTRA_ARGS ="LOADADDR=0x20008000"
-PR = "r14"
+PR = "r15"
PKGR_kernel-module-i2c-at91 = "${PR}a${EXTENDPRAUTO}"
PKGR_kernel-module-atmel-mci = "${PR}a${EXTENDPRAUTO}"
KERNEL_VERSION = "${PV}"
@@ -41,9 +41,9 @@ COMMON_PATCHES = " \
file://defconfig \
file://linux-4.9-pps-gpio.patch \
file://linux-4.9-at91sam9_wdt-10second-timeout.patch \
- file://linux-4.9-spidev_squack.patch \
- file://linux-4.9-add-num_accessory_ports-config-option.patch \
- file://linux-4.9-cdc-acm-ignore-exar-devices.patch \
+ file://linux-4.9-spidev_squack.patch \
+ file://linux-4.9-add-num_accessory_ports-config-option.patch \
+ file://linux-4.9-cdc-acm-ignore-exar-devices.patch \
file://EXTRAVERSION.patch \
file://linux-4.9-ledtrig-netdev.patch \
file://linux-4.9-addl-time-for-pmeccerrloc.patch \
@@ -60,7 +60,10 @@ COMMON_PATCHES = " \
SRC_URI_append_mtcdt = "\
${COMMON_PATCHES} \
+ file://mtcdt.dts \
+ file://mt-at91.h \
file://linux-4.9-mtcdt-device-tree.patch \
+ file://linux-4.9-mtcdt-atmel-multidrop.patch \
"
SRC_URI_append_mtrv1 = "\
${COMMON_PATCHES} \
@@ -124,6 +127,10 @@ kernel_do_configure_append() {
rm -f ${B}/.scmversion ${S}/.scmversion
cd ${S}; git status; cd -
}
+kernel_do_configure_append_mtcdt() {
+ cp ${WORKDIR}/mtcdt.dts ${S}/arch/arm/boot/dts
+ cp ${WORKDIR}/mt-at91.h ${S}/arch/arm/boot/dts/include/dt-bindings/gpio
+}
KERNEL_MODULE_PACKAGE_SUFFIX=""