summaryrefslogtreecommitdiff
path: root/recipes-bsp/u-boot/u-boot_2016.09.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot_2016.09.01.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot_2016.09.01.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot_2016.09.01.bb b/recipes-bsp/u-boot/u-boot_2016.09.01.bb
new file mode 100644
index 0000000..59b3c4c
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot_2016.09.01.bb
@@ -0,0 +1,34 @@
+require u-boot.inc
+
+DEPENDS += "dtc-native"
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-2016.09.01:"
+
+SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 \
+ file://kconfig_common.patch \
+ file://config.patch \
+ file://i2c.patch \
+ file://printeepromcrc.patch \
+ file://mtpwd.patch \
+ file://tftpput.patch \
+ file://hide_uboot_version.patch \
+ file://fix_2_6.patch \
+ file://fix_net.patch"
+
+SRC_URI_append_mtcdt = " \
+ file://mtcdt.patch \
+ file://mtcdt_flush_console_autoboot.patch"
+
+SRC_URI_append_mtcap = " \
+ file://mtcdt.patch"
+
+SRC_URI_append_mtr = "\
+ file://mtr.patch \
+"
+SRC_URI_append_mtrv1 = "\
+ file://mtrv1.patch \
+"
+
+SRC_URI[md5sum] = "61c628f8034477c946e173ed174efeb4"
+SRC_URI[sha256sum] = "95728e89dd476d17428f94080752ab48884be477b6a678941582aeef618b70bb"
+
+S = "${WORKDIR}/${PN}-${PV}"