summaryrefslogtreecommitdiff
path: root/recipes-bsp/ti-wifi-utils/ti-wifi-utils
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/ti-wifi-utils/ti-wifi-utils')
-rw-r--r--recipes-bsp/ti-wifi-utils/ti-wifi-utils/plt_drop_insmod_rmmod.patch35
-rw-r--r--recipes-bsp/ti-wifi-utils/ti-wifi-utils/upgrade_libnl_to_32.patch28
2 files changed, 63 insertions, 0 deletions
diff --git a/recipes-bsp/ti-wifi-utils/ti-wifi-utils/plt_drop_insmod_rmmod.patch b/recipes-bsp/ti-wifi-utils/ti-wifi-utils/plt_drop_insmod_rmmod.patch
new file mode 100644
index 0000000..5bdafef
--- /dev/null
+++ b/recipes-bsp/ti-wifi-utils/ti-wifi-utils/plt_drop_insmod_rmmod.patch
@@ -0,0 +1,35 @@
+--- a/plt.c 2016-05-31 17:23:45.000000000 +0300
++++ b/plt.c 2016-05-31 18:04:25.022788401 +0300
+@@ -1158,10 +1158,10 @@
+ }
+
+ /* Load module */
+- res = insmod(modpath);
+- if (res) {
+- goto out_removenvs;
+- }
++// res = insmod(modpath);
++// if (res) {
++// goto out_removenvs;
++// }
+
+ res = plt_do_power_on(state, devname);
+ if (res < 0)
+@@ -1188,7 +1188,7 @@
+
+ /* we can ignore the return value, because we rmmod anyway */
+ plt_do_power_off(state, devname);
+- rmmod(modpath);
++// rmmod(modpath);
+
+ printf("Calibration done. ");
+ if (cmn.fem0_bands) {
+@@ -1214,7 +1214,7 @@
+ /* we can ignore the return value, because we rmmod anyway */
+ plt_do_power_off(state, devname);
+ out_rmmod:
+- rmmod(modpath);
++// rmmod(modpath);
+
+ out_removenvs:
+ fprintf(stderr, "Calibration not complete. Removing half-baked nvs\n");
diff --git a/recipes-bsp/ti-wifi-utils/ti-wifi-utils/upgrade_libnl_to_32.patch b/recipes-bsp/ti-wifi-utils/ti-wifi-utils/upgrade_libnl_to_32.patch
new file mode 100644
index 0000000..c5b6efa
--- /dev/null
+++ b/recipes-bsp/ti-wifi-utils/ti-wifi-utils/upgrade_libnl_to_32.patch
@@ -0,0 +1,28 @@
+--- a/Makefile 2016-05-31 17:23:45.000000000 +0300
++++ b/Makefile 2016-05-31 17:36:55.582844952 +0300
+@@ -1,21 +1,12 @@
+ CC = $(CROSS_COMPILE)gcc
+ CFLAGS = -O2 -Wall
+-CFLAGS += -I$(NFSROOT)/usr/include -I$(NFSROOT)/include
++CFLAGS += -I=/usr/include -I=/include -I=/usr/include/libnl3
+
+-ifdef NLROOT
+-CFLAGS += -I${NLROOT}
+-endif
+-
+-LDFLAGS += -L$(NFSROOT)/lib
++LDFLAGS += -L=/lib
+ LIBS += -lm
+
+-ifeq ($(NLVER),3)
+- CFLAGS+=-DCONFIG_LIBNL32
+- LIBS += -lnl-3 -lnl-genl-3
+-else
+- CFLAGS+=-DCONFIG_LIBNL20
+- LIBS += -lnl -lnl-genl
+-endif
++CFLAGS+=-DCONFIG_LIBNL32
++LIBS += -lnl-3 -lnl-genl-3
+
+ OBJS = nvs.o misc_cmds.o calibrator.o plt.o wl18xx_plt.o ini.o
+