summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/driver.inc1
-rw-r--r--recipes-kernel/linux/linux-at91-4.9.87/defconfig2
-rw-r--r--recipes-kernel/linux/linux-at91_4.9.87.bb1
3 files changed, 3 insertions, 1 deletions
diff --git a/recipes-kernel/linux/driver.inc b/recipes-kernel/linux/driver.inc
index 5e21ed6..823997b 100644
--- a/recipes-kernel/linux/driver.inc
+++ b/recipes-kernel/linux/driver.inc
@@ -11,6 +11,7 @@ DRIVER_LOAD_ALL_MACHINES = " \
KERNEL_MODULE_AUTOLOAD_mtcdt += " \
${DRIVER_LOAD_ALL_MACHINES} \
g_serial \
+ softdog \
"
diff --git a/recipes-kernel/linux/linux-at91-4.9.87/defconfig b/recipes-kernel/linux/linux-at91-4.9.87/defconfig
index 3c0173e..79285b4 100644
--- a/recipes-kernel/linux/linux-at91-4.9.87/defconfig
+++ b/recipes-kernel/linux/linux-at91-4.9.87/defconfig
@@ -2191,7 +2191,7 @@ CONFIG_WATCHDOG_CORE=y
#
# Watchdog Device Drivers
#
-# CONFIG_SOFT_WATCHDOG is not set
+CONFIG_SOFT_WATCHDOG=m
# CONFIG_GPIO_WATCHDOG is not set
# CONFIG_XILINX_WATCHDOG is not set
# CONFIG_ZIIRAVE_WATCHDOG is not set
diff --git a/recipes-kernel/linux/linux-at91_4.9.87.bb b/recipes-kernel/linux/linux-at91_4.9.87.bb
index ca25d99..7811947 100644
--- a/recipes-kernel/linux/linux-at91_4.9.87.bb
+++ b/recipes-kernel/linux/linux-at91_4.9.87.bb
@@ -15,6 +15,7 @@ inherit linux-append-dtb
RDEPENDS_${KERNEL_PACKAGE_NAME}-base=""
+RDEPENDS_kernel-modules_remove = "kernel-module-softdog"
FILESEXTRAPATHS_prepend := "${THISDIR}/${P}:"
KERNEL_EXTRA_ARGS ="LOADADDR=0x20008000"