summaryrefslogtreecommitdiff
path: root/recipes-kernel/rsi-91x/rsi-91x-utils_2.6.1.bb
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2023-08-22 09:18:17 -0500
committerJohn Klug <john.klug@multitech.com>2023-08-22 09:18:17 -0500
commitb9d90d071db617bd845293612f41fcb1059f5911 (patch)
tree9d1485fe34b48bb0179a6341437a43bc42a4ea72 /recipes-kernel/rsi-91x/rsi-91x-utils_2.6.1.bb
parentf85d2259ea400e6313e86915f81079736394d563 (diff)
parent20def296509899676b8d812032fc0e70ec06541e (diff)
downloadmeta-multitech-atmel-b9d90d071db617bd845293612f41fcb1059f5911.tar.gz
meta-multitech-atmel-b9d90d071db617bd845293612f41fcb1059f5911.tar.bz2
meta-multitech-atmel-b9d90d071db617bd845293612f41fcb1059f5911.zip
Merge branch 'vp/update_rs911x_driver' into '6'
MTX-5053 Update RS911x driver to v. 2.6.1 See merge request !36
Diffstat (limited to 'recipes-kernel/rsi-91x/rsi-91x-utils_2.6.1.bb')
-rw-r--r--recipes-kernel/rsi-91x/rsi-91x-utils_2.6.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-kernel/rsi-91x/rsi-91x-utils_2.6.1.bb b/recipes-kernel/rsi-91x/rsi-91x-utils_2.6.1.bb
new file mode 100644
index 0000000..9f5d7ff
--- /dev/null
+++ b/recipes-kernel/rsi-91x/rsi-91x-utils_2.6.1.bb
@@ -0,0 +1,31 @@
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+PR = "r3"
+
+RDEPENDS_${PN} += "bash"
+
+SRCREV = "v${PV}"
+SRC_URI = "git://github.com/SiliconLabs/RS911X-nLink-OSD.git;protocol=https \
+ file://onebox_util.sh \
+ "
+S = "${WORKDIR}/git/rsi/apps"
+
+FILES_${PN} = "${base_libdir} ${prefix} /opt"
+TARGET_CC_ARCH += "${LDFLAGS}"
+do_install() {
+ instdir="${D}/opt/rs9113"
+ install -m 0755 -d ${D}${prefix}/share/${PN}
+ sed -n '5,17p' ${S}/onebox_util.c >${D}${prefix}/share/${PN}/LICENSE
+ install -m 0755 -d ${instdir}
+ cd "${S}"
+ for f in $(find . -type f) ; do
+ if file "$f" | grep ELF ; then
+ if [ "$f" = "./onebox_util" ] ; then
+ install -m 0755 $f ${instdir}/onebox_util_rsi
+ else
+ install -m 0755 $f ${instdir}
+ fi
+ fi
+ done
+ install -m 0755 ${WORKDIR}/onebox_util.sh ${instdir}/onebox_util
+}