summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Hatch <jhatch@multitech.com>2020-07-22 12:14:29 -0500
committerJeff Hatch <jhatch@multitech.com>2020-07-22 12:14:29 -0500
commit21829d77488651a43699b1757b6880616c7870a2 (patch)
tree40f08ff81533ac3b2ebbcf7a19e502eeb01c326f
parent924098ad3f648f06719cee25334744c1e51bb717 (diff)
parent36eb51b917f1e018c158e260a2de85647dfff262 (diff)
downloadmeta-multitech-atmel-21829d77488651a43699b1757b6880616c7870a2.tar.gz
meta-multitech-atmel-21829d77488651a43699b1757b6880616c7870a2.tar.bz2
meta-multitech-atmel-21829d77488651a43699b1757b6880616c7870a2.zip
Merge branch 'vs/feature-diff-upgrade' into 'master'
move make-kernel-reproducible.patch to meta-multitech-atmel See merge request !4
-rw-r--r--recipes-kernel/linux/linux-at91-4.9.87/make-kernel-reproducible.patch25
-rw-r--r--recipes-kernel/linux/linux-at91_4.9.87.bb3
2 files changed, 27 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-at91-4.9.87/make-kernel-reproducible.patch b/recipes-kernel/linux/linux-at91-4.9.87/make-kernel-reproducible.patch
new file mode 100644
index 0000000..7b92dd2
--- /dev/null
+++ b/recipes-kernel/linux/linux-at91-4.9.87/make-kernel-reproducible.patch
@@ -0,0 +1,25 @@
+From 7977646874531a08430becc339ae03472648d481 Mon Sep 17 00:00:00 2001
+From: Serhii Voloshynov <serhii.voloshynov@globallogic.com>
+Date: Fri, 12 Jun 2020 11:58:38 +0300
+Subject: [PATCH] make kernel reproducible
+
+---
+ Makefile | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/Makefile b/Makefile
+index 3043937..b92e80d 100644
+--- a/Makefile
++++ b/Makefile
+@@ -651,6 +651,8 @@ KBUILD_CFLAGS += -O2
+ endif
+ endif
+
++KBUILD_CFLAGS += $(call cc-option,-fmacro-prefix-map=$(srctree)/=)
++
+ KBUILD_CFLAGS += $(call cc-ifversion, -lt, 0409, \
+ $(call cc-disable-warning,maybe-uninitialized,))
+
+--
+2.7.4
+
diff --git a/recipes-kernel/linux/linux-at91_4.9.87.bb b/recipes-kernel/linux/linux-at91_4.9.87.bb
index a3b2e83..05cef2a 100644
--- a/recipes-kernel/linux/linux-at91_4.9.87.bb
+++ b/recipes-kernel/linux/linux-at91_4.9.87.bb
@@ -49,6 +49,7 @@ COMMON_PATCHES = " \
file://linux-4.9-linux4sam-usb-serial-option.patch \
file://0001-linux-4.9-quectel_qmi_wwan_support.patch \
file://0002-linux-4.9-telit_print_qmi_wwan.patch \
+ file://make-kernel-reproducible.patch \
"
@@ -157,4 +158,4 @@ do_install_append() {
cp -a ${STAGING_KERNEL_DIR}/include/dt-bindings ${STAGING_DIR_TARGET}/${includedir}/linux
}
-FILES_kernel-dt-bindings-dev = "/usr/include/linux/dt-bindings"
+FILES_kernel-dt-bindings-dev = "/usr/include/linux/dt-bindings" \ No newline at end of file