summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Hatch <jhatch@multitech.com>2022-02-02 13:00:17 -0600
committerJeff Hatch <jhatch@multitech.com>2022-02-02 13:00:17 -0600
commit688e292f2e8cfe6bb7b0f007bf96977803d7921f (patch)
tree461dab4f5b440cb41be231b892f4114b0d448c87
parent7e4b9d572916f02cf95889837c140ec9aa428c42 (diff)
parentca8bd04a87d1390d6c6d3905bb4e917bd12384dd (diff)
downloadmeta-multitech-atmel-688e292f2e8cfe6bb7b0f007bf96977803d7921f.tar.gz
meta-multitech-atmel-688e292f2e8cfe6bb7b0f007bf96977803d7921f.tar.bz2
meta-multitech-atmel-688e292f2e8cfe6bb7b0f007bf96977803d7921f.zip
Merge branch 'vs/mtx-4338' into '6'
Vs/mtx 4338 See merge request !22
-rw-r--r--recipes-bsp/at91bootstrap/at91bootstrap-3.8.12/0005-at91bootstrap-3.8-mtcdt.patch9
-rw-r--r--recipes-bsp/at91bootstrap/at91bootstrap_3.8.12.bb2
-rw-r--r--recipes-bsp/u-boot/u-boot-2016.09.01/config.patch16
-rw-r--r--recipes-bsp/u-boot/u-boot.inc2
4 files changed, 21 insertions, 8 deletions
diff --git a/recipes-bsp/at91bootstrap/at91bootstrap-3.8.12/0005-at91bootstrap-3.8-mtcdt.patch b/recipes-bsp/at91bootstrap/at91bootstrap-3.8.12/0005-at91bootstrap-3.8-mtcdt.patch
index eb8d60d..a0b3e60 100644
--- a/recipes-bsp/at91bootstrap/at91bootstrap-3.8.12/0005-at91bootstrap-3.8-mtcdt.patch
+++ b/recipes-bsp/at91bootstrap/at91bootstrap-3.8.12/0005-at91bootstrap-3.8-mtcdt.patch
@@ -1,7 +1,12 @@
+ Pin PIOa 7 is resetting to Periph B, SPI0_NPCS1
+ This might be part of the CPU design for booting
+ from SPI NAND. This conflicts with our usage as
+ an input from the USB Host port.
+========================================================================================
diff -Naru orig/board/at91sam9x5ek/at91sam9x5ek.c new/board/at91sam9x5ek/at91sam9x5ek.c
--- orig/board/at91sam9x5ek/at91sam9x5ek.c 2020-09-10 16:30:43.653327254 -0500
+++ new/board/at91sam9x5ek/at91sam9x5ek.c 2020-09-10 16:16:38.597352272 -0500
-@@ -56,6 +56,48 @@
+@@ -56,6 +56,50 @@
writel(0xFF, RTC_SCCR + AT91C_BASE_RTC);
}
@@ -36,10 +41,12 @@ diff -Naru orig/board/at91sam9x5ek/at91sam9x5ek.c new/board/at91sam9x5ek/at91sam
+ {"GNSS-RESET",AT91C_PIN_PD(15), 0, PIO_PULLUP, PIO_OUTPUT},
+ {"MTQ-RESET",AT91C_PIN_PD(17), 1, PIO_PULLUP, PIO_OUTPUT},
+ {"USBHUB-RESET",AT91C_PIN_PD(18), 0, PIO_PULLUP, PIO_OUTPUT},
++ {"N_USB_HOST_OC",AT91C_PIN_PA(7), 0, PIO_DEFAULT, PIO_INPUT},
+ {"GNSS-INT",AT91C_PIN_PD(19), 1, PIO_PULLUP, PIO_OUTPUT},
+ {"WIFI-BT-LPMODE",AT91C_PIN_PD(20), 0, PIO_PULLUP, PIO_INPUT},
+ {"N_GPIO_EXP1_RESET",AT91C_PIN_PD(16), 1, PIO_DEFAULT, PIO_OUTPUT},
+ {"N_GPIO_EXP2_RESET",AT91C_PIN_PC(26), 1, PIO_DEFAULT, PIO_OUTPUT},
++ {"WM_LINK_MON",AT91C_PIN_PA(14), 0, PIO_DEFAULT, PIO_INPUT},
+ {(char *)0, 0, 0, PIO_DEFAULT, PIO_PERIPH_A},
+ };
+
diff --git a/recipes-bsp/at91bootstrap/at91bootstrap_3.8.12.bb b/recipes-bsp/at91bootstrap/at91bootstrap_3.8.12.bb
index a92f928..d1bbb38 100644
--- a/recipes-bsp/at91bootstrap/at91bootstrap_3.8.12.bb
+++ b/recipes-bsp/at91bootstrap/at91bootstrap_3.8.12.bb
@@ -1,5 +1,5 @@
require at91bootstrap.inc
-PR = "m7"
+PR = "m8"
LIC_FILES_CHKSUM = "file://main.c;endline=27;md5=a2a70db58191379e2550cbed95449fbd"
diff --git a/recipes-bsp/u-boot/u-boot-2016.09.01/config.patch b/recipes-bsp/u-boot/u-boot-2016.09.01/config.patch
index 658fdec..51fcb1e 100644
--- a/recipes-bsp/u-boot/u-boot-2016.09.01/config.patch
+++ b/recipes-bsp/u-boot/u-boot-2016.09.01/config.patch
@@ -1,6 +1,10 @@
-diff -Naru old/configs/at91sam9x5ek_nandflash_defconfig new/configs/at91sam9x5ek_nandflash_defconfig
---- old/configs/at91sam9x5ek_nandflash_defconfig 2019-04-09 18:00:13.342337484 -0500
-+++ new/configs/at91sam9x5ek_nandflash_defconfig 2019-04-15 12:06:49.171618119 -0500
+ CONFIG_CMD_SF brings in SPI flash baggage and sets up SPI for the Atmel
+ AT91SAM9X5EK board, which does not match our usage of pins in the pioA 7
+ through pioA 20 region.
+======================================================================================
+diff -Naru orig/configs/at91sam9x5ek_nandflash_defconfig new/configs/at91sam9x5ek_nandflash_defconfig
+--- orig/configs/at91sam9x5ek_nandflash_defconfig 2022-01-24 16:08:01.151798695 -0600
++++ new/configs/at91sam9x5ek_nandflash_defconfig 2022-01-24 16:24:37.851818785 -0600
@@ -1,9 +1,9 @@
CONFIG_ARM=y
CONFIG_ARCH_AT91=y
@@ -13,11 +17,13 @@ diff -Naru old/configs/at91sam9x5ek_nandflash_defconfig new/configs/at91sam9x5ek
CONFIG_HUSH_PARSER=y
CONFIG_SYS_PROMPT="U-Boot> "
CONFIG_CMD_BOOTZ=y
-@@ -12,7 +12,7 @@
+@@ -11,8 +11,8 @@
+ # CONFIG_CMD_IMLS is not set
# CONFIG_CMD_FLASH is not set
CONFIG_CMD_MMC=y
- CONFIG_CMD_SF=y
+-CONFIG_CMD_SF=y
-CONFIG_CMD_USB=y
++# CONFIG_CMD_SF=y is not set
+CONFIG_CMD_USB=n
# CONFIG_CMD_FPGA is not set
# CONFIG_CMD_SETEXPR is not set
diff --git a/recipes-bsp/u-boot/u-boot.inc b/recipes-bsp/u-boot/u-boot.inc
index 800c48e..c69c650 100644
--- a/recipes-bsp/u-boot/u-boot.inc
+++ b/recipes-bsp/u-boot/u-boot.inc
@@ -4,7 +4,7 @@ SECTION = "bootloaders"
PROVIDES = "virtual/bootloader"
# New U-Boot with suppressed version.
-PR="m4"
+PR="m5"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"