summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2020-10-15 18:26:56 -0500
committerJohn Klug <john.klug@multitech.com>2021-06-23 05:05:41 -0500
commit150eaba7eb4878ece96ec23bf2ead9c3787def57 (patch)
tree1f508ff554de8b81539262a07265231a894e05bf
parent7b1c9f2f7a51add2e4299364e0bcef48b0d04123 (diff)
downloadmeta-multitech-atmel-150eaba7eb4878ece96ec23bf2ead9c3787def57.tar.gz
meta-multitech-atmel-150eaba7eb4878ece96ec23bf2ead9c3787def57.tar.bz2
meta-multitech-atmel-150eaba7eb4878ece96ec23bf2ead9c3787def57.zip
Add Cell-LDO-Enable pin to bootstrap
-rw-r--r--recipes-bsp/at91bootstrap/at91bootstrap-3.8.12/0005-at91bootstrap-3.8-mtcap.patch3
-rw-r--r--recipes-bsp/at91bootstrap/at91bootstrap_3.8.12.bb2
2 files changed, 3 insertions, 2 deletions
diff --git a/recipes-bsp/at91bootstrap/at91bootstrap-3.8.12/0005-at91bootstrap-3.8-mtcap.patch b/recipes-bsp/at91bootstrap/at91bootstrap-3.8.12/0005-at91bootstrap-3.8-mtcap.patch
index 3574be1..4a52903 100644
--- a/recipes-bsp/at91bootstrap/at91bootstrap-3.8.12/0005-at91bootstrap-3.8-mtcap.patch
+++ b/recipes-bsp/at91bootstrap/at91bootstrap-3.8.12/0005-at91bootstrap-3.8-mtcap.patch
@@ -1,7 +1,7 @@
diff -Naru orig/board/at91sam9x5ek/at91sam9x5ek.c new/board/at91sam9x5ek/at91sam9x5ek.c
--- orig/board/at91sam9x5ek/at91sam9x5ek.c 2020-09-10 14:47:38.921510351 -0500
+++ new/board/at91sam9x5ek/at91sam9x5ek.c 2020-09-10 12:29:01.089756599 -0500
-@@ -56,6 +56,31 @@
+@@ -56,6 +56,32 @@
writel(0xFF, RTC_SCCR + AT91C_BASE_RTC);
}
@@ -13,6 +13,7 @@ diff -Naru orig/board/at91sam9x5ek/at91sam9x5ek.c new/board/at91sam9x5ek/at91sam
+ {"PA14-UNUSED",AT91C_PIN_PA(14), 0, PIO_PULLUP, PIO_INPUT},
+ {"LORA-32MHZ-CLOCK",AT91C_PIN_PA(26), 0, PIO_DEFAULT, PIO_INPUT},
+ {"LORA-CRESET",AT91C_PIN_PA(29), 0, PIO_PULLUP, PIO_OUTPUT},
++ {"CELL-LDO-ENABLE",AT91C_PIN_PB(11), 0, PIO_DEFAULT, PIO_OUTPUT},
+ {"MP8859-ENABLE",AT91C_PIN_PB(12), 0, PIO_DEFAULT, PIO_OUTPUT},
+ {"POE-AT-STATUS",AT91C_PIN_PB(15), 0, PIO_PULLUP, PIO_INPUT},
+ {"PB18-UNUSED",AT91C_PIN_PB(18), 0, PIO_PULLUP, PIO_INPUT},
diff --git a/recipes-bsp/at91bootstrap/at91bootstrap_3.8.12.bb b/recipes-bsp/at91bootstrap/at91bootstrap_3.8.12.bb
index daf807d..b8e5ba9 100644
--- a/recipes-bsp/at91bootstrap/at91bootstrap_3.8.12.bb
+++ b/recipes-bsp/at91bootstrap/at91bootstrap_3.8.12.bb
@@ -1,5 +1,5 @@
require at91bootstrap.inc
-PR = "m3"
+PR = "m5"
LIC_FILES_CHKSUM = "file://main.c;endline=27;md5=a2a70db58191379e2550cbed95449fbd"