summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Klug <john.klug@multitech.com>2021-01-04 16:33:01 -0600
committerJohn Klug <john.klug@multitech.com>2021-06-23 05:46:13 -0500
commit4cc1d45adf8bd0157698314916309d763b951be1 (patch)
treefd0452be3b8e628a4e3ad445a65fd87e820b1798
parent314ffb57afb98f52eaed06c11710226ed05e1686 (diff)
downloadmeta-multitech-atmel-4cc1d45adf8bd0157698314916309d763b951be1.tar.gz
meta-multitech-atmel-4cc1d45adf8bd0157698314916309d763b951be1.tar.bz2
meta-multitech-atmel-4cc1d45adf8bd0157698314916309d763b951be1.zip
Add softdog to the feeds (no images)
-rw-r--r--recipes-kernel/linux/driver.inc1
-rw-r--r--recipes-kernel/linux/linux-at91-4.9.87/defconfig2
-rw-r--r--recipes-kernel/linux/linux-at91_4.9.87.bb1
3 files changed, 3 insertions, 1 deletions
diff --git a/recipes-kernel/linux/driver.inc b/recipes-kernel/linux/driver.inc
index 5e21ed6..823997b 100644
--- a/recipes-kernel/linux/driver.inc
+++ b/recipes-kernel/linux/driver.inc
@@ -11,6 +11,7 @@ DRIVER_LOAD_ALL_MACHINES = " \
KERNEL_MODULE_AUTOLOAD_mtcdt += " \
${DRIVER_LOAD_ALL_MACHINES} \
g_serial \
+ softdog \
"
diff --git a/recipes-kernel/linux/linux-at91-4.9.87/defconfig b/recipes-kernel/linux/linux-at91-4.9.87/defconfig
index 3c0173e..79285b4 100644
--- a/recipes-kernel/linux/linux-at91-4.9.87/defconfig
+++ b/recipes-kernel/linux/linux-at91-4.9.87/defconfig
@@ -2191,7 +2191,7 @@ CONFIG_WATCHDOG_CORE=y
#
# Watchdog Device Drivers
#
-# CONFIG_SOFT_WATCHDOG is not set
+CONFIG_SOFT_WATCHDOG=m
# CONFIG_GPIO_WATCHDOG is not set
# CONFIG_XILINX_WATCHDOG is not set
# CONFIG_ZIIRAVE_WATCHDOG is not set
diff --git a/recipes-kernel/linux/linux-at91_4.9.87.bb b/recipes-kernel/linux/linux-at91_4.9.87.bb
index ca25d99..7811947 100644
--- a/recipes-kernel/linux/linux-at91_4.9.87.bb
+++ b/recipes-kernel/linux/linux-at91_4.9.87.bb
@@ -15,6 +15,7 @@ inherit linux-append-dtb
RDEPENDS_${KERNEL_PACKAGE_NAME}-base=""
+RDEPENDS_kernel-modules_remove = "kernel-module-softdog"
FILESEXTRAPATHS_prepend := "${THISDIR}/${P}:"
KERNEL_EXTRA_ARGS ="LOADADDR=0x20008000"