summaryrefslogtreecommitdiff
path: root/recipes-support/ntp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/ntp')
-rw-r--r--recipes-support/ntp/files/ntpd-init.patch11
-rw-r--r--recipes-support/ntp/ntp_4.2.6p5.bbappend11
2 files changed, 22 insertions, 0 deletions
diff --git a/recipes-support/ntp/files/ntpd-init.patch b/recipes-support/ntp/files/ntpd-init.patch
new file mode 100644
index 0000000..fc388f8
--- /dev/null
+++ b/recipes-support/ntp/files/ntpd-init.patch
@@ -0,0 +1,11 @@
+--- old/ntpd 2016-12-19 18:11:58.022663976 -0600
++++ new/ntpd 2016-12-19 18:12:56.618663852 -0600
+@@ -23,7 +23,7 @@
+ # this. If ntpd seems to disappear after a while assume TICKADJ
+ # above is set to a totally incorrect value.
+ echo -n "Starting ntpd: "
+- start-stop-daemon --start -x /usr/sbin/ntpd -- -u ntp:ntp -p /var/run/ntp.pid "$@"
++ start-stop-daemon -N -20 --start -x /usr/sbin/ntpd -- -u ntp:ntp -p /var/run/ntp.pid "$@"
+ echo "done"
+ }
+ stopdaemon(){
diff --git a/recipes-support/ntp/ntp_4.2.6p5.bbappend b/recipes-support/ntp/ntp_4.2.6p5.bbappend
new file mode 100644
index 0000000..528c6c9
--- /dev/null
+++ b/recipes-support/ntp/ntp_4.2.6p5.bbappend
@@ -0,0 +1,11 @@
+PR .= ".mlinux1"
+
+SRC_URI += " file://ntpd-init.patch;patchdir=.. \
+ "
+FILESEXTRAPATHS_prepend := "${THISDIR}/files"
+
+python do_patch_prepend () {
+ import os
+ cwd = os.getcwd()
+ bb.note("Hello %s",cwd)
+}