summaryrefslogtreecommitdiff
path: root/recipes-support/ntp/ntp_4.2.6p5.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/ntp/ntp_4.2.6p5.bbappend')
-rw-r--r--recipes-support/ntp/ntp_4.2.6p5.bbappend26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-support/ntp/ntp_4.2.6p5.bbappend b/recipes-support/ntp/ntp_4.2.6p5.bbappend
new file mode 100644
index 0000000..4651611
--- /dev/null
+++ b/recipes-support/ntp/ntp_4.2.6p5.bbappend
@@ -0,0 +1,26 @@
+PR .= ".mlinux1"
+
+SRC_URI += " file://ntpd-init.patch;patchdir=.. \
+ file://ntp.conf.patch;patchdir=.. \
+ "
+FILESEXTRAPATHS_prepend := "${THISDIR}/files"
+
+python do_patch_prepend () {
+ import os
+}
+pkg_postinst_${PN} () {
+ if ! [[ -d /var/log/ntpstats ]] ; then
+ mkdir -p /var/log/ntpstats
+ fi
+ chown ntp:ntp /var/log/ntpstats
+ chmod 775 /var/log/ntpstats
+
+ if ! [[ -d /var/lib/ntp ]] ; then
+ mkdir -p /var/lib/ntp
+ fi
+ drfile="/var/lib/ntp/ntp.drift"
+ touch ${drfile}
+ chown ntp:ntp ${drfile}
+ chmod 664 ${drfile}
+}
+