summaryrefslogtreecommitdiff
path: root/recipes-support/lxfp/lxfp-src_23a2843.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/lxfp/lxfp-src_23a2843.bb')
-rw-r--r--recipes-support/lxfp/lxfp-src_23a2843.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-support/lxfp/lxfp-src_23a2843.bb b/recipes-support/lxfp/lxfp-src_23a2843.bb
new file mode 100644
index 0000000..b2258b7
--- /dev/null
+++ b/recipes-support/lxfp/lxfp-src_23a2843.bb
@@ -0,0 +1,33 @@
+# This recipe needs a manual download of
+# the proprietary Telit firmware flashing
+# program into build/downloads
+# Then it will be able to compile an
+# ipk. The current lxfp recipe requires
+# a tar file of bin/lxfp object module.
+# This is here is an example only.
+DESCRIPTION = "Telit LXFP modem flashing tools"
+LICENSE = ""
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2ccdd50f62f8ac0b28"
+
+PR = "r1"
+
+SRC_URI = " \
+ file://lxfp-${PV}.tar.gz;md5=b4dc2f536658b3f82c91b68af1bf3dc3 \
+"
+
+S = "${WORKDIR}/lxfp-${PV}"
+
+do_compile() {
+ CC="${CC} --sysroot=${STAGING_DIR_HOST}"
+ LD="${LD} --sysroot=${STAGING_DIR_HOST}"
+ CXX="${CXX} --sysroot=${STAGING_DIR_HOST}"
+ echo "CXX is ${CXX}"
+ oe_runmake CC="${CC}" LD="${LD}" CXX="${CXX}"
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 0755 bin/lxfp ${D}${sbindir}
+}
+
+FILES_${PN} = "${sbindir}/lxfp"