summaryrefslogtreecommitdiff
path: root/recipes-support/jsoncpp/jsoncpp_1.6.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/jsoncpp/jsoncpp_1.6.0.bb')
-rw-r--r--recipes-support/jsoncpp/jsoncpp_1.6.0.bb19
1 files changed, 9 insertions, 10 deletions
diff --git a/recipes-support/jsoncpp/jsoncpp_1.6.0.bb b/recipes-support/jsoncpp/jsoncpp_1.6.0.bb
index 80f3f70..8c8454d 100644
--- a/recipes-support/jsoncpp/jsoncpp_1.6.0.bb
+++ b/recipes-support/jsoncpp/jsoncpp_1.6.0.bb
@@ -4,10 +4,6 @@ HOMEPAGE = "https://github.com/open-source-parsers/jsoncpp"
LICENSE = "PD"
LIC_FILES_CHKSUM = "file://LICENSE;md5=c56ee55c03a55f8105b969d8270632ce"
DEPENDS = ""
-BBCLASSEXTEND = "native"
-
-# static lib only, require staticdev
-RDEPENDS_${PN}-dev = "${PN}-staticdev"
#tag 1.6.0
SRCREV="cbe7e7c9cbd39d864588c5cf2436690634562d3f"
@@ -16,7 +12,7 @@ SRC_URI = " git://github.com/open-source-parsers/jsoncpp.git;protocol=git \
file://Makefile \
"
-PR = "r1"
+PR = "r6"
S = "${WORKDIR}/git"
@@ -25,10 +21,13 @@ do_compile() {
oe_runmake
}
-do_install() {
- oe_runmake install DESTDIR=${D}
+do_install () {
+ install -d ${D}/usr/lib
+ install -m 0755 ${S}/libjsoncpp.so ${D}/usr/lib
+ install -d ${D}${includedir}/jsoncpp/json
+ install -m 0755 ${S}/include/json/*.h ${D}${includedir}/jsoncpp/json
}
-# this recipe provides dev packages only (static lib)
-PACKAGES = "${PN}-dev ${PN}-staticdev ${PN}-dbg"
-
+FILES_SOLIBSDEV = ""
+FILES_${PN} += "${libdir}/*.so"
+FILES_{PN}-dev += "${libdir}/*.so"