summaryrefslogtreecommitdiff
path: root/recipes-support/jsoncpp/jsoncpp_0.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/jsoncpp/jsoncpp_0.5.0.bb')
-rw-r--r--recipes-support/jsoncpp/jsoncpp_0.5.0.bb21
1 files changed, 9 insertions, 12 deletions
diff --git a/recipes-support/jsoncpp/jsoncpp_0.5.0.bb b/recipes-support/jsoncpp/jsoncpp_0.5.0.bb
index 18f1c86..aa4880a 100644
--- a/recipes-support/jsoncpp/jsoncpp_0.5.0.bb
+++ b/recipes-support/jsoncpp/jsoncpp_0.5.0.bb
@@ -1,27 +1,25 @@
DESCRIPTION = "Json C++ Library"
-HOMEPAGE = "http://jsoncpp.sourceforge.net/"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+HOMEPAGE = "https://github.com/open-source-parsers/jsoncpp"
+# Public Domain
+LICENSE = "PD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=f7c191d0ae6a652f63b2d2bc1ea8bdab"
DEPENDS = ""
BBCLASSEXTEND = "native"
-NATIVE_INSTALL_WORKS = "1"
+
+SRCREV = "svn-release-0.5.0"
SRC_URI = " \
- http://sw.multitech.prv/openembedded/sources/jsoncpp-src-0.5.0.tar.gz \
+ git://github.com/open-source-parsers/jsoncpp.git;nobranch=1 \
file://jsoncpp-0.5.0-p1.patch \
file://Makefile \
"
PR = "r2"
-# For tarball packages (as opposed to git / svn which include the commit in the URI)
-SRC_URI[md5sum] = "24482b67c1cb17aac1ed1814288a3a8f"
-SRC_URI[sha256sum] = "22b14ecd0de8cdad2b6b6839f6d0804d3b84e91f42861ebd843832a26a927433"
-
-S = "${WORKDIR}/jsoncpp-src-${PV}"
+S = "${WORKDIR}/git"
do_compile() {
- cp ../Makefile .
+ cp ${WORKDIR}/Makefile .
oe_runmake
}
@@ -29,4 +27,3 @@ do_install() {
oe_runmake install DESTDIR=${D}
}
-