summaryrefslogtreecommitdiff
path: root/recipes-support/dnsmasq/dnsmasq_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-support/dnsmasq/dnsmasq_%.bbappend')
-rw-r--r--recipes-support/dnsmasq/dnsmasq_%.bbappend14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes-support/dnsmasq/dnsmasq_%.bbappend b/recipes-support/dnsmasq/dnsmasq_%.bbappend
new file mode 100644
index 0000000..6aa39f8
--- /dev/null
+++ b/recipes-support/dnsmasq/dnsmasq_%.bbappend
@@ -0,0 +1,14 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI += "\
+ file://init.patch;patchdir=.. \
+ file://default \
+ "
+
+do_install_append () {
+ install -d ${D}${sysconfdir}/ ${D}${sysconfdir}/default
+ install -m 755 ${WORKDIR}/default ${D}${sysconfdir}/default/dnsmasq
+}
+
+# init.d/dnsmasq conflicts with AEP.
+CONFFILES_${PN} += "${sysconfdir}/init.d/dnsmasq"