summaryrefslogtreecommitdiff
path: root/recipes-ruby/ruby-serialport/ruby-serialport_1.3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-ruby/ruby-serialport/ruby-serialport_1.3.1.bb')
-rw-r--r--recipes-ruby/ruby-serialport/ruby-serialport_1.3.1.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-ruby/ruby-serialport/ruby-serialport_1.3.1.bb b/recipes-ruby/ruby-serialport/ruby-serialport_1.3.1.bb
index d06be09..8f524e3 100644
--- a/recipes-ruby/ruby-serialport/ruby-serialport_1.3.1.bb
+++ b/recipes-ruby/ruby-serialport/ruby-serialport_1.3.1.bb
@@ -17,6 +17,8 @@ SRC_URI = "git://github.com/hparra/ruby-serialport.git;protocol=git"
S = "${WORKDIR}/git"
B = "${S}"
+CFLAGS_append +="-fPIC"
+
do_compile() {
rp=$(ls -d ${STAGING_INCDIR}/ruby-* | head -1)
${CC} -v ${CFLAGS} ${LDFLAGS} -Iext/native -I${rp} -I${rp}/arm-linux-gnueabi -c ext/native/*.c