summaryrefslogtreecommitdiff
path: root/recipes-navigation/gpsd/gpsd_3.20.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-navigation/gpsd/gpsd_3.20.bb')
-rw-r--r--recipes-navigation/gpsd/gpsd_3.20.bb54
1 files changed, 47 insertions, 7 deletions
diff --git a/recipes-navigation/gpsd/gpsd_3.20.bb b/recipes-navigation/gpsd/gpsd_3.20.bb
index 2cf7b67..ba1b33e 100644
--- a/recipes-navigation/gpsd/gpsd_3.20.bb
+++ b/recipes-navigation/gpsd/gpsd_3.20.bb
@@ -4,7 +4,11 @@ LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=01764c35ae34d9521944bb6ab312af53"
DEPENDS = "dbus dbus-glib ncurses python3 libusb1 chrpath-replacement-native pps-tools"
PROVIDES = "virtual/gpsd"
-PR="m1"
+PR="m6"
+
+#TODO
+#the recipe generates python2 pygps package for Atmel based devices and python3 pygps package for TI based devices.
+#later when python2 will be removed the recipe should be returned to previous version
EXTRANATIVEPATH += "chrpath-native"
@@ -33,6 +37,7 @@ SRC_URI[sha256sum] = "172a7805068eacb815a3c5225436fcb0be46e7e49a5001a94034eac43d
inherit scons update-rc.d python3-dir python3native systemd
+INITSCRIPT_PACKAGES = "gpsd-conf"
INITSCRIPT_NAME = "gpsd"
INITSCRIPT_PARAMS = "defaults 10"
@@ -49,6 +54,8 @@ PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez',
PACKAGECONFIG[bluez] = "bluez='false',${BLUEZ}"
PACKAGECONFIG[qt] = "qt='yes',qt='no',qt4-x11-free"
+PYTHON2_SITEPACKAGES_DIR="${libdir}/python2.7/site-packages"
+
# Remove unneeded features. netfeed is needed by gpsmon
EXTRA_OESCONS = " \
sysroot=${STAGING_DIR_TARGET} \
@@ -146,6 +153,8 @@ do_install_append() {
#support for python
install -d ${D}/${PYTHON_SITEPACKAGES_DIR}/gps
install -m 755 ${S}/gps/*.py ${D}/${PYTHON_SITEPACKAGES_DIR}/gps
+ install -d ${D}/${PYTHON2_SITEPACKAGES_DIR}/gps
+ install -m 755 ${S}/gps/*.py ${D}/${PYTHON2_SITEPACKAGES_DIR}/gps
#support for systemd
install -d ${D}${systemd_unitdir}/system/
@@ -165,8 +174,12 @@ do_install_append() {
# New ubxtool
install -m 0755 ${S}/ubxtool ${D}/${bindir}
#install -m 0644 ${S}/ubxtool.1 ${D}/${mandir}/man1
+ install -m 0644 ${S}/gps.h ${D}/${includedir}
+ install -m 0644 ${S}/timespec.h ${D}/${includedir}
+ install -m 0644 ${S}/libgpsmm.h ${D}/${includedir}
}
+RDEPENDS_${PN} += "bash"
RDEPENDS_${PN}-conf += "bash"
pkg_postinst_${PN}-conf() {
@@ -177,21 +190,25 @@ pkg_postrm_${PN}-conf() {
update-alternatives --remove gpsd-defaults ${sysconfdir}/default/gpsd.default
}
-PACKAGES =+ "libgps libgpsd python3-pygps-dbg python3-pygps gpsd-udev gpsd-conf gpsd-gpsctl gpspipe gps-utils"
+
+PACKAGES =+ "libgps libgpsd gpsd-udev gpsd-conf gpsd-gpsctl gpspipe gps-utils python-pygps-dbg python-pygps python3-pygps-dbg python3-pygps"
+# PACKAGES =+ "${PN} ${PN}-dbg ${PN}-dev"
# File does not exist: ${libdir}/libQgpsmm.prl
-FILES_${PN}-dev += "${libdir}/pkgconfdir/libgpsd.pc ${libdir}/pkgconfdir/libgps.pc \
+FILES_${PN}-dev += "${libdir}/pkgconfig/libgpsd.pc ${libdir}/pkgconfig/libgps.pc \
${libdir}/libQgpsmm.prl \
${includedir}/gps.h ${includedir}/libgpsmm.h ${includedir}/gps"
FILES_${PN} += "${sbindir}/gpsd_*"
+FILES_${PN}-doc += "${docdir}"
-FILES_python3-pygps-dbg += " ${libdir}/python*/site-packages/gps/.debug"
+FILES_${PN}-conf = "${sysconfdir}/default ${sysconfdir}/init.d"
-RDEPENDS_${PN} = "gpsd-gpsctl bash"
+
+RDEPENDS_${PN}-conf = "gpsd-gpsctl bash"
# gpsd-udev is for USB, which we are not using
-RRECOMMENDS_${PN} = "gpsd-conf gpsd-machine-conf"
+# RRECOMMENDS_${PN} = "gpsd-conf gpsd-machine-conf"
SUMMARY_${PN}-udev = "udev relevant files to use gpsd hotplugging"
FILES_${PN}-udev = "${base_libdir}/udev ${sysconfdir}/udev/*"
@@ -215,11 +232,14 @@ FILES_gpspipe = "${bindir}/gpspipe"
SUMMARY_gps-utils = "Utils used for simulating, monitoring,... a GPS"
FILES_gps-utils = "${bindir}/*"
+RDEPENDS_gps-utils_mtbsp-at91 = "python-pygps"
RDEPENDS_gps-utils = "python3-pygps"
+SUMMARY_python-pygps = "Python bindings to gpsd"
SUMMARY_python3-pygps = "Python bindings to gpsd"
+FILES_python-pygps = "${PYTHON2_SITEPACKAGES_DIR}/*"
FILES_python3-pygps = "${PYTHON_SITEPACKAGES_DIR}/*"
-RDEPENDS_python-pygps = " \
+RDEPENDS_python3-pygps = " \
python3-core \
python3-io \
python3-threading \
@@ -228,6 +248,15 @@ RDEPENDS_python-pygps = " \
gpsd \
python3-json"
+RDEPENDS_python-pygps = " \
+ python-core \
+ python-io \
+ python-threading \
+ python-terminal \
+ python-curses \
+ gpsd \
+ python-json"
+
RPROVIDES_${PN} += "${PN}-systemd"
RREPLACES_${PN} += "${PN}-systemd"
RCONFLICTS_${PN} += "${PN}-systemd"
@@ -237,3 +266,14 @@ SYSTEMD_SERVICE_${PN} = "${BPN}.socket ${BPN}ctl@.service"
ALTERNATIVE_${PN} = "gpsd-defaults"
ALTERNATIVE_LINK_NAME[gpsd-defaults] = "${sysconfdir}/default/gpsd"
ALTERNATIVE_TARGET[gpsd-defaults] = "${sysconfdir}/default/gpsd.default"
+
+
+FILES_${PN}-dev_append = " ${includedir}/gps.h ${includedir}/timespec.h ${includedir}/libgpsmm.h ${includedir}/gps ${libdir}/libgps.so"
+FILES_${PN}-dev_remove = "${includedir} ${FILES_SOLIBSDEV} \
+ ${libdir}/*.la ${libdir}/*.o ${libdir}/pkgconfig \
+ ${datadir}/pkgconfig ${datadir}/aclocal \
+ ${base_libdir}/*.o ${libdir}/${BPN}/*.la ${base_libdir}/*.la"
+
+SUMMARY_${PN}-dbg = "Debug the C service library used for communicating with gpsd"
+
+FILES_${PN}-dbg_replace = "${prefix}/src/* ${libdir}/.debug/*"