summaryrefslogtreecommitdiff
path: root/recipes-navigation/gpsd/gpsd-test_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-navigation/gpsd/gpsd-test_1.0.bb')
-rw-r--r--recipes-navigation/gpsd/gpsd-test_1.0.bb11
1 files changed, 5 insertions, 6 deletions
diff --git a/recipes-navigation/gpsd/gpsd-test_1.0.bb b/recipes-navigation/gpsd/gpsd-test_1.0.bb
index 7753bcc..903a4ed 100644
--- a/recipes-navigation/gpsd/gpsd-test_1.0.bb
+++ b/recipes-navigation/gpsd/gpsd-test_1.0.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "gpsd reboot testing"
SECTION = "base"
PRIORITY = "optional"
LICENSE = "GPLv2+"
-PR = "r1"
+PR = "r2"
inherit allarch
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
FILESEXTRAPATHS_prepend = "${THISDIR}/test:"
@@ -15,12 +15,11 @@ FILES_${PN} = "*"
RDEPENDS_${PN} = "bash"
do_install() {
- echo "Directory is ${D}"
cp -a * ${D}
cd ${D}
- chown -R root:root *
- chmod 755 ${prefix}/local/bin/*
- chmod 755 ${sysconfdir}/rc5.d/*
+ chown -R root:root .
+ chmod 755 ${D}/${prefix}/local/bin/*
+ chmod 755 ${D}/${sysconfdir}/rc5.d/*
}
pkg_postinst_${PN}() {
@@ -34,4 +33,4 @@ pkg_prerm_${PN}() {
if [ -z "$D" ] ; then
rm /var/config/reboot
fi
-} \ No newline at end of file
+}