summaryrefslogtreecommitdiff
path: root/recipes-navigation/gpsd/gpsd-test_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-navigation/gpsd/gpsd-test_1.0.bb')
-rw-r--r--recipes-navigation/gpsd/gpsd-test_1.0.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-navigation/gpsd/gpsd-test_1.0.bb b/recipes-navigation/gpsd/gpsd-test_1.0.bb
new file mode 100644
index 0000000..7753bcc
--- /dev/null
+++ b/recipes-navigation/gpsd/gpsd-test_1.0.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "gpsd reboot testing"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "GPLv2+"
+PR = "r1"
+inherit allarch
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+FILESEXTRAPATHS_prepend = "${THISDIR}/test:"
+SRC_URI = " \
+ file://gpsd-test-1.0.tar.gz \
+ "
+
+FILES_${PN} = "*"
+
+RDEPENDS_${PN} = "bash"
+
+do_install() {
+ echo "Directory is ${D}"
+ cp -a * ${D}
+ cd ${D}
+ chown -R root:root *
+ chmod 755 ${prefix}/local/bin/*
+ chmod 755 ${sysconfdir}/rc5.d/*
+}
+
+pkg_postinst_${PN}() {
+ if [ -z "$D" ] ; then
+ touch /var/config/reboot
+ fi
+}
+
+
+pkg_prerm_${PN}() {
+ if [ -z "$D" ] ; then
+ rm /var/config/reboot
+ fi
+} \ No newline at end of file