summaryrefslogtreecommitdiff
path: root/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/logrotate/logrotate_3.8.7.bbappend7
1 files changed, 4 insertions, 3 deletions
diff --git a/recipes-extended/logrotate/logrotate_3.8.7.bbappend b/recipes-extended/logrotate/logrotate_3.8.7.bbappend
index 98b7b60..300b9b7 100644
--- a/recipes-extended/logrotate/logrotate_3.8.7.bbappend
+++ b/recipes-extended/logrotate/logrotate_3.8.7.bbappend
@@ -1,8 +1,9 @@
+PR .= "mlinux1"
do_install_append() {
-# rotate logs hourly instead of daily
+ # setup cron to run logrotate more often
rm -f ${D}${sysconfdir}/cron.daily/logrotate
- install -d ${D}${sysconfdir}/cron.hourly
- install -p -m 755 examples/logrotate.cron ${D}${sysconfdir}/cron.hourly/logrotate
+ install -d ${D}${sysconfdir}/cron.d
+ echo "*/5 * * * * root /usr/sbin/logrotate /etc/logrotate.conf" > ${D}${sysconfdir}/cron.d/logrotate
}