summaryrefslogtreecommitdiff
path: root/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/logrotate/logrotate_3.8.7.bbappend8
1 files changed, 8 insertions, 0 deletions
diff --git a/recipes-extended/logrotate/logrotate_3.8.7.bbappend b/recipes-extended/logrotate/logrotate_3.8.7.bbappend
new file mode 100644
index 0000000..98b7b60
--- /dev/null
+++ b/recipes-extended/logrotate/logrotate_3.8.7.bbappend
@@ -0,0 +1,8 @@
+
+do_install_append() {
+# rotate logs hourly instead of daily
+ rm -f ${D}${sysconfdir}/cron.daily/logrotate
+ install -d ${D}${sysconfdir}/cron.hourly
+ install -p -m 755 examples/logrotate.cron ${D}${sysconfdir}/cron.hourly/logrotate
+}
+