summaryrefslogtreecommitdiff
path: root/recipes-extended/multitech/set-rs485_0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/multitech/set-rs485_0.2.bb')
-rw-r--r--recipes-extended/multitech/set-rs485_0.2.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-extended/multitech/set-rs485_0.2.bb b/recipes-extended/multitech/set-rs485_0.2.bb
new file mode 100644
index 0000000..09fe9f9
--- /dev/null
+++ b/recipes-extended/multitech/set-rs485_0.2.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Enables RS485 mode for a serial tty device"
+HOMEPAGE = "http://www.multitech.net/"
+PRIORITY = "optional"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+PR = "r0"
+
+SRC_URI = "file://set-rs485.c"
+S = "${WORKDIR}"
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LDFLAGS} -o set-rs485 set-rs485.c
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 set-rs485 ${D}${bindir}/
+}