summaryrefslogtreecommitdiff
path: root/recipes-extended/logrotate/logrotate_3.8.7.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/logrotate/logrotate_3.8.7.bbappend')
-rw-r--r--recipes-extended/logrotate/logrotate_3.8.7.bbappend8
1 files changed, 7 insertions, 1 deletions
diff --git a/recipes-extended/logrotate/logrotate_3.8.7.bbappend b/recipes-extended/logrotate/logrotate_3.8.7.bbappend
index 300b9b7..577fe53 100644
--- a/recipes-extended/logrotate/logrotate_3.8.7.bbappend
+++ b/recipes-extended/logrotate/logrotate_3.8.7.bbappend
@@ -1,9 +1,15 @@
-PR .= "mlinux1"
+PR .= "mlinux2"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}"
+
+SRC_URI += "file://logrotate.conf"
do_install_append() {
# setup cron to run logrotate more often
rm -f ${D}${sysconfdir}/cron.daily/logrotate
install -d ${D}${sysconfdir}/cron.d
echo "*/5 * * * * root /usr/sbin/logrotate /etc/logrotate.conf" > ${D}${sysconfdir}/cron.d/logrotate
+
+ install -m 0644 ${WORKDIR}/logrotate.conf ${D}${sysconfdir}/
}