summaryrefslogtreecommitdiff
path: root/recipes-extended/lighttpd/lighttpd_1.4.33.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/lighttpd/lighttpd_1.4.33.bbappend')
-rw-r--r--recipes-extended/lighttpd/lighttpd_1.4.33.bbappend18
1 files changed, 17 insertions, 1 deletions
diff --git a/recipes-extended/lighttpd/lighttpd_1.4.33.bbappend b/recipes-extended/lighttpd/lighttpd_1.4.33.bbappend
index 885737e..5ef310b 100644
--- a/recipes-extended/lighttpd/lighttpd_1.4.33.bbappend
+++ b/recipes-extended/lighttpd/lighttpd_1.4.33.bbappend
@@ -1,5 +1,21 @@
+PR .= "mlinux1"
+
# build with openssl support
DEPENDS += " openssl "
-RDEPENDS_${PN} += " openssl "
+RDEPENDS_${PN} += " openssl logrotate "
EXTRA_OECONF += "--with-openssl"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}"
+
+SRC_URI += "file://lighttpd.logrotate.conf \
+ file://lighttpd.default"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/logrotate.d
+ install -d ${D}${sysconfdir}/default
+ install -m 0644 ${WORKDIR}/lighttpd.logrotate.conf ${D}${sysconfdir}/logrotate.d/lighttpd.conf
+ install -m 0644 ${WORKDIR}/lighttpd.default ${D}${sysconfdir}/default/lighttpd
+}
+
+CONFFILES_${PN} += "${sysconfdir}/default/lighttpd ${sysconfdir}/logrotate.d/lighttpd.conf"