summaryrefslogtreecommitdiff
path: root/recipes-devtools/node-red/node-red_0.15.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/node-red/node-red_0.15.3.bb')
-rw-r--r--recipes-devtools/node-red/node-red_0.15.3.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/recipes-devtools/node-red/node-red_0.15.3.bb b/recipes-devtools/node-red/node-red_0.15.3.bb
index ae3d6e7..d9e9672 100644
--- a/recipes-devtools/node-red/node-red_0.15.3.bb
+++ b/recipes-devtools/node-red/node-red_0.15.3.bb
@@ -3,6 +3,7 @@ HOMEPAGE = "http://nodered.org"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
DEPENDS = "nodejs nodejs-native"
+RDEPENDS_${PN} += "bash"
PR = "r0"
inherit npm
@@ -15,7 +16,10 @@ do_install() {
oe_runnpm install --prefix ./ node-red@0.15.3
# npm install more stuff
- oe_runnpm install --prefix ./node_modules/node-red serialport nodemailer
+ oe_runnpm install --prefix./node_modules/node-red nodemailer
+ # Build patched serialport.
+ # Original is https://registry.npmjs.org/serialport/-/serialport-1.7.4.tgz
+ oe_runnpm install --prefix ./node_modules/node-red http://multitech.net/mlinux/sources/node-red-serialport-1.7.4-mt1.tgz
# modules needed for loragw
oe_runnpm install --prefix ./node_modules/node-red extend dissolve node-constants
@@ -32,6 +36,9 @@ do_install() {
rm ./node_modules/node-red/nodes/core/hardware/nrgpio
rm ./node_modules/node-red/nodes/core/hardware/nrgpio.py
+ # remove x86_64 serialport 0.0.5
+ rm -rf ./node_modules/node-red/node_modules/node-red-node-serialport
+
# install node-red
install -d ${D}/opt/node-red
cp -r ./node_modules/node-red/* ${D}/opt/node-red/