summaryrefslogtreecommitdiff
path: root/recipes-devtools/node-red/node-red_0.11.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/node-red/node-red_0.11.1.bb')
-rw-r--r--recipes-devtools/node-red/node-red_0.11.1.bb9
1 files changed, 6 insertions, 3 deletions
diff --git a/recipes-devtools/node-red/node-red_0.11.1.bb b/recipes-devtools/node-red/node-red_0.11.1.bb
index 1dba51a..0eb3ab6 100644
--- a/recipes-devtools/node-red/node-red_0.11.1.bb
+++ b/recipes-devtools/node-red/node-red_0.11.1.bb
@@ -4,6 +4,8 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
DEPENDS = "nodejs nodejs-native"
PR = "r0"
+FILESEXTRAPATHS_prepend := ":${THISDIR}/files:"
+SRC_URI += "file://errnopatch.txt"
inherit npm-base
@@ -15,10 +17,11 @@ do_install() {
# npm install locally
oe_runnpm install --prefix ./ node-red@0.11.1
+ # Patch for 6.2 compiler and errno overload issue
+ patch -N -p1 <errnopatch.txt
+
# npm install more stuff
- # serialport dropped because of compiler error (g++ 6.2) in morty:
- #
- oe_runnpm install --prefix ./node_modules/node-red nodemailer
+ oe_runnpm install --prefix ./node_modules/node-red nodemailer serialport
# modules needed for loragw
oe_runnpm install --prefix ./node_modules/node-red extend dissolve node-constants